Communication with the web service encountered a protocol exception


3 Days before, All of my Apps that using TinywebDB has problem as bellow. Those Apps are not use HTML or PHPs. When Blocks to getvalue, it is not working. I am trying to fix it and visit many web site. and I could not get any solution.
Please help Me~~~

Hubert Lee


The MIT tinyWebDB service is working OK here, so possibly a connection issue at your end ?

Thank you very much to pay attention.
I confirmed GCP already and I could not find how to fix it.
I tried with P/C emulator, my Mobile phone, and others Mobile Phone, and Other Applications that I made.
All of my Apps made by me have same problem. So I could not find how to solve it.
It might be GCP system because it happened to all my Apps that I made when I want getvalue with Tinyweb thru Applications. It never happened I mentioned. Steel I can not edit my Apps thru MIT AI2 because to many block asking Getvalues. If it happened only a App that I made, then I can Edit other Application. Is anyone has solution ?
Please help me.

What happens if you create a new app with tinywebDB? Same problem?

When I start my applications,
case A-> 1st, Log-in and Getvalue from tinywebdb and it is not connect to sever.
case b-> some of menu asks to Getvalue as as avove.
In case A, B are same problem.
So I think that it not AI2 matter, its GCP's problem. All of my Apps that I made send me same
message bellow.
All of my Apps, before last Saterday had no problem. And I asked to Google agent and waiting reply for it.

error message as bellow in case A.

thank so much.

Dear TIMAI2,

I am still in the critical problem.
I ca not make or edit any more with this problem.
Around 5 days I could not edit or update my Apps.

without using Getvalue of tinywebdb I can not make any application for the project.

It might be GCP system for me. any how I do not know about it.

Please Help Me~~~~

Explain GCP - I assume this is Google Cloud Project? Are you running just a tinywedb service from GCP or a full app Inventor?

I am re-writing for reply.
GCP = Google Cloud Platform and Project, Datastore as sample as bellow.

When app call getvalue(tag) and value, shows Error message as I mentioned.
I am running tinywebdb sevice from GCP.
I do not understand that "a full app Inventor".
You mean that AI2? Then Yes.

OK, are you using the MIT App Inventor server for your apps or your own app inventor server ?

What guide did you follow to create your tinywebdb service ?

As previously requested, can you create a test app that demonstrates this problem ?

I do not understand clearly what u say.
--> are you using the MIT App Inventor server for your apps or your own app inventor server ?
I am using GCP, Google Cloud Project(tinywebDB), DataStore. I have no my own server.

I made sample.



Did you follow this guide to set up your tinywebdb service ?

or this?

Thank you,

I will review it and take some time.


I confirmed that a Tinywebdb over 10,000 records. and I deleted more than 1000 records just before to confirm whether there is a limit entities.
After delete records, My app shows same message.

I think that there is no problem for Apps. and Using GCP and Tinywebdb might be problem to fix it.

Anyhow I appreciate your suggestion.

Hi ^,^
I tried so many time to fix my Apps.
I am still in problem, I have no idea for that.
I think It's GCP system's matter, because it's showed same for Other apps that I made long times before.
And I am reviewing GCP's authorization for me, but I have no solution for that. Is anybody to got this problem? Please let me Know to fix it~~~~
And I appreciate TIMAI2.

I am sorry to say that I am still in trouble as I told above.
Is there no situation as I suggested?

All of my apps are not working that using tinyWebDbs.

I think It's GCP problem, but I don.t know how to fix it.
Please help me^,^

I am happy to fix it.
It caused GCP Project account matter.
But I can not explain in detail.
When someone met same as I were in trouble,
U must confirm GCP Projects Accounts(?).

Thank you, TIMAI2.

I experienced the same problem when using Tinywebdb.Getvalue()

I explored the source code from GitHub and I guessed there's a bug on the postCommandReturningArray() method on the file appinventor/components/src/com/google/appinventor/components/runtime/util/

Btw, I don't understand much about Java, all by trial and error.

App Inventor source code:

So, I made a new custom extension based on appinventor/components/src/com/google/appinventor/components/runtime/

In the new extension, I replaced postCommandReturningArray() in GetValue() function with postCommand(), as used by the Storevalue() function.

It has been successful, although in the GotValue event became has no tagFromWebDB parameter. But it's no problem, I still can read the response from the server and manipulate it.

I am still testing this extension, I will publish it later.

This is the main modification:

    // Replace this.....
    // WebServiceUtil.getInstance().postCommandReturningArray(
    // With this 

        Lists.<NameValuePair>newArrayList(new BasicNameValuePair(TAG_PARAMETER, tag)),


is a fix that works for many people....