Come here if it keeps said "your companian disconnected"

i cant....i was reading on epic to learn how to program apps and when i tested it, it said "the companian disconnected" i thought its just my wifi so i did it again but said the same things, i did it 10 times and guess what, STILL THE SAME MESSAGE EVEN THO I HAVE A WIFI AND DOWNLOADED THE TEST APP, ugh pls fix it I EVEN USED BLUETOOTH BUT STILL THE SAME MESSAGE OVER AND OVER AGAIN, ARE THEY STOPPING ME FROM TESTING?

Using capital letters is like !!SHOUTING!!, please edit your first post.

Also please do not spam the community with duplicate posts.

You do not tell us about the environment you are using to "test an app" with the companion. Please provide as many details as possible to make it possible for others to help you.


bruh. can someone atleast tell me HOW TO FIX THIS BUGS???????? i was just programming and was about to test my first and old applications with my companian when suddenly the first thing is that there's an message saying "the companian has disconnected" i thought its just a simple bug but when i do it tenth time, IT KEEPS SAYING THE SAME MESSAGE, EVEN WHEN I HAD MY BLUETOOTH ON >:( pls fix it

oh sorry, i was just an 9 year old who wanna learn how to code

Show your blocks and post a screenshot of the message.
Try with an almost empty app (e.g. only Screen1 and only 1 Button, no blocks?

but the text is not the same tho.

theres 1 screen1 and 1 button and 1 label, i didnt wanna use up all my computer memory

Are you using a phone to test your app?

Could it be going to sleep?

Have you tried installing an emulator for testing?

1 Like

For what?

App Inventor is an online IDE, not an offline IDE.

Probably you did not set it up correctly, or you are using Emulator, Please show us your blocks!!

Please don't use capitals!