CloudDBError: Socket closed


I was working with CloudDB and everything seems to be fine but whenever I try to clear the CloudDB tags then this ERROR appears and it never gets deleted.

Please help me if you can

I am not able to replicate your issue testing on the MIT provided cloudDB. (Is that what you are using, or your own redis server?)

It looks like a connection error of some kind. Do you have good internet access ?

1 Like

I have a good internet connection but no matter what I do the CloudDB just doesn't want to get cleared

This post is just for clarification, but @TIMAI2 has stated a 2nd question as well:

Are you testing in companion app or with compiled app ?

You could also show more of your relevant blocks, which may help to define the issue ?

The error pops up when I use it in the companion app and doesn't clear the CloudDB.
On the compiled app, it doesn't show an error but also doesn't clear the CloudDB

I am using the provided redis server

Try to clear just one tag. Do you still get the error?
It could be that making 10 requests at once is overloading the server?

This approach works for me:


It still didn't work, shows the same error

Hmmm, I am not getting any errors and even you method works.

  • Check this is all correct


  • Try like this, see what comes back


  • You could also try a new project see if that exhibits the same behaviour.

  • Restarting your browser might also be worth a try

I've tried the methods you mentioned but the Socket Error just doesn't want to go, none of the tags get deleted.

For "When CloudDB Error" block, it doesn't send any message to the label that I placed there. Like it doesn't even detect an error

Am I the first one to have this problem? I couldn't find anything related to this

I do not know what else it could be. Perhaps @jis (CloudDB creator) can shed some light ?

1 Like

What happens if you just clear one tag, not a whole bunch at once?

-Jeff (who maintains the CloudDB component and server)


Then the error disappears but isn't there a way to keep it working normally even when I clear multiple tags?

Be happy. Perhaps you can not clear all the tags as fast as the for each number cycles through the Tags. You could try a Clock to send the ClearTag slower. That might fix your issue. Try a Clock to slow the ClearTag to give the online server some time to react to the instruction. Let us know what happens.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.