Cloud DB Acting Weirdly [Urgent Help Needed]

Hello friends, I am making an app which uses Cloud DB. I have a big problem with it -
When I get the tag-list from the DB is showing differently in different screen.
This is what i got-

["Users", "ShopsAndShopkeepers", "User1", "User2"]



It is very urgent, Thank you :slightly_smiling_face:

I think you know how important blocks/ aia are important to help.

I have used these same blocks in both the screen-

Can anyone please help? Its very urgent :pleading_face:

I can't duplicate this with a test aia
clouddb2Screens.aia (3.5 KB)
( I did get an error on Screen2 the first time I ran getTagList, but it worked 2nd time around)

Do your ProjectIDs, Servers, Ports,SSL and Tokens match on both screens ?

Yes, they are same

If the problem persists, put the aia file with this problem here.

Do anyone have any idea? :pleading_face:

Your help will be highly appreciated :smiling_face_with_three_hearts:

  • The issue may be how you use your different screen. You say you used the same blocks on both screens. Did you place a second CloudDb control on the other screen? The issue could be a second instance of the CloudDb control. We can't see your Blocks Alpha.
  • Patryk recommended you share your aia file. You do not have to do that but it would help debug if you made a Project using different Screens that exhibits the same behavior.
  • Urgent? Provide an example that demonstrates the code fails. Your issue may have something to do with switching screens and the fact that a separate Screen behaves like it is a separate app.
  • a work around is to use virtual screens rather than an actual separate Screen. Did you try that?

Thank you @SteveJG, I am working on a solution. It will take some time, than I will say if it worked or not.
Thank you

Thank you all for your help..... I worked on it and found a solution.
This is what I did-
I went to the working screen and retrieved all data needed for the other screen. No I have now problem with it

Thank you :smiling_face_with_three_hearts:

The Problem is that when I created the checkpoint the project ID changed.

Sorry I didnt noticed that :sweat_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.