Clock event doesn't seem to fire

Tried reading whats happening but I cannot see why this fails. The routine just runs through with no break. I have tried moving the code to write to text box and speach to clock but then the app never stops. I have read other topics about clock but not seen this issue.

What are you trying to achieve ?

At the moment, it should randomly pick a name, write it to text box, speak it then wait 5000 ms before choosing next. Loop is for 5 times.

Try this

clock_name.aia (2.8 KB)

1 Like

How do Iuse that?
Sorry, new

Download file, then go to, click on projects, Import project (aia) from my computer

Afterwards you can check my code and test it in companion or an emulator to see how it works

Cheers for that. Is there away to reduce the chance of the random pick not picking the same item twice?

Yes it is possible. Check

clock_name_revised.aia (3.3 KB)

Ah, should have said. I want to keep the list. was thinking , maybe store the previous 3 or 4 picks

going to try


1 Like