Checklist error, >= cannot accept argument

Hello, I am trying to make a checklist. I found an aia on here that was similar to what I wanted to do. It's called multiselect. I tried to replicate but using some data from my google sheet. It worked but only when I altered one of the block codes but the output is not exactly what I wanted. So I went back to the original aia file and in the blocks, the list data had the number 1 - 12, I just tried to edit it and used A - L but it didn't work. I tried again editing a block just as I did when I tried to replicate it. It works but the output is exactly the same as my checklist... Idk how to fix the issue.

Here is the aia file: multiselect.aia (3.4 KB)

Here is a screen shot of how it should work:

-First I chose 1 then I chose 7, it is in the right order 1 then 7

-Then I selected 7 again and it goes right back to it's original spot between 6 and 8

Now if I change it from 1 - 7 to A - L this error pops up once I try to select something for the second time:

Once I changed the block code from >= to = at the part with the question mark it'll work

But how it works is:

-Then I tried selecting the "k" back but it does not go back to it's original spot

What should I do?

use Do it to debug your blocks, see also tip 4 here App Inventor: How to Learn | Pura Vida Apps
see also Live Development, Testing, and Debugging Tools

Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

I tried to use Do It, but i'm unsure of what I should put in the boxes where it asks for the values. I still tried to manually input it like the input item that i want selected is "d" then the list is "b,d,c,e,f,g,h,i,j,k,l" no a because I already selected and the insert point was already initialized as 1 in the blocks so I added 1 as the value. It shows an erros of:

Still not quite sure on what to do....

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

blocks (5)

Here are the blocks

why is there a red cross (i.e. an error) displayed in that block? probably you just forgot to clear that error...
who is the author of that example? where did you find the example? any link?
to debug a while loop is a bit difficult... you have to do it manually step by step...


Yeah I forgot to clear the error, I forgot from which topic I got it from but here is the link that has the author:

ok... the author is @ABG... he might want to give you a hint...

Ouhhh okay, should I private message him or just tag him in this topic and hope that he replies? I'm not sure what is appropriate to do to ask for his help...

you only have to wait and be patient...
I already assigned this thread to him


1 Like

Thank you so much :grin: :grin:

Hi, I'm back online.

At first glance, I have two observations ...

  • the procedure merge_a_number works only with numbers. It has a comment on it in the doc telling how to get it to work with text, like you fed it, using the text compare block. If you don't want to try that yourself, I could bulletproof and generalize this further.
  • The Do It facility is at a great disadvantage in the middle of procedures and events. It's like trying to use a microscope to look at the cells of a live animal in the act of running away from you. You have to copy the blocks in question and drop them off to the side, out of the running data flow, and spoon feed them literals or global variables then try your Do It on the blocks, like a microscope slide.

Here is an updated version of the app, using mixed numeric and non-numeric list items, respecting the two different comparison techniques for numeric vs non-numeric data ...

multiselect.aia (3.9 KB) when btnReset Click when screen1 Initialize

1 Like

Thank you soo much for this, I was so confused why it couldn't work unless i changed it to and equal because my data from my list were all in string format. I appreciate the help so much :smiling_face_with_three_hearts:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.