Can't open apk after i installed it

After i installed the apk file from MIT app inventor2, i found it in "My Files"(app) and i clicked the apk file again. (I set the download unknown installed permission to allow) But it pops up something like this
Screenshot_20240409_160049_Package installer
How can i fix it?

If you have installed any previous version try to uninstall it before. If you are using any extension try to remove it and test to find out if the error is caused by some extension.

Have you decompiled and then recompiled your apk? It may need resigning and zip aligning.

yea, I tried different program in my library which doesn't have any extension but it didn't work.
btw I used s21 samsung and a9 tab to download and failed but I used a8s samsung(very old version model) and it works. I am confused.

it sounds a bit hard for me to understand, can you tell me more, please?

What does that mean?

When did you compile your app?

I mean that my old model phone can download that apk and open it but my latest phone can't (I did in the same day which is today) Plus, I tried to download another program that doesn't have any extension but my latest phone can't download it even though it's in "My Files".