Can't load program into iPad

I have tried to download the program written in Appinventor platform into iPad through scanning the QR Code. When it is downloaded about 80%, it can't be downloaded. I have tried many times, but the results are the same. Is it because they are not in the same domain of the networks? Can I download the program to iPad with the usb cable instead?

Thanks,
Raymond

APK on iOS?

Sorry you cannot download using USB at present.
See Evan's comments here> Help on AI on Ipads .

If the Project is only loading at 80% there could be issues with your Project.

Be aware, the Companion for ios is only an interpreter. You can only run your Project using Companion. MIT is still testing the builder and has not released it other than for a small group that is testing it.

This is likely the issue. The iOS version uses what is called "Legacy" connection mode on the Android version. This requires that the computer and the iOS device be on the same network such that the two devices can talk to each other, and specifically on port 8001. A future update will support WebRTC connectivity, which allows for things like using the iOS device over cellular.

@ewpatton Is it already possible to roughly estimate when WebRTC connection mode will likely be available for the iOS Companion?
Or is there a public repo where the work on the iOS Companion is done? I couldn't find anything on Github.

Thanks!