Can't connect to ELEGOO BT16 Module

The BT-16 Bluetooth module is a BLE module. It’s not a normal Bluetooth 2.0 module. It came in the Elegoo smart car kit 3.0, I am attempting to create a custom app to send information to the car. Therefore I used this article:
to download a BluetoothLE extension and attempt connecting to the car. This was unsuccessful as the device did not show up on the list of devices. It shows up on the list of Bluetooth devices on my phone but it can only be connected through to by their custom Elegoo BLE tool app. I need to connect to the device using my custom MIT app so I'd appreciate any advice.

Export your project as you have to a .aia file and share it here.

APS_App.aia (662.6 KB)

I looked at the blocks. Correct your UUID.

I see how that may be the issue but:

  1. It doesnt even show up so that block isn't even used yet
  2. This is a message i got from the support team the sold me the module: The server of the BT16 Bluetooth module is FFE0, WriteCharacteristic is FFE2, and SubscribeCharacteristic is FFE1.

I've also tried with other UUId and it doesnt change the fact that the module doesn't appear in the list of devices that i can connect to

What you are writing about is this part.

I have tried that UUId but it doesn't show up on the lsit regardless

Are any other BT modules listed? Have you granted location permissions to your application?

So if i use a normal bluetooth and not BLe then some of my other devices show up but with this Ble the only ones that show up are address codes

Your application connects to my HM-10 module. Scan your devices, open the list and take a screenshot.

Ignore the button test1 btw. I'll take a screenshot now

But the list changes every time I hit scan tbh

  • I click "Scan"
  • I click the list button, the one with the BT graphic
  • I choose the address of my module
  • I click "Connect"
  • the application correctly connects to the module, the LED on my module lights up so it's ok.

Alright but the issue isn't my Bluetooth module cause it connects to their app and an app called lightBlue.
This is the BT-16 module i believe.

Do you test with companion or did you compile the APK?

You can also download some BLE scanner from the Play Store. See if the scanner finds your module. What is its name and what address.

I use the QR scanner to get the APK on my device

THe LightBlue app is the scanner app, It's name is ELEGOO BT16 with address: 48:87:2D:14:39:56

I think it should work:

APS_App_ok.aia (662.8 KB)

Now a few words about the problems that I found quickly:

We don't use TinyDb this way. As you can see, there is a red stamp indicating an error.

We download the data from TinyDB to a variable in the screen initialize block.

However, the problem with searching for devices was here:

I think as soon as the first device was found, the search was aborted.
The scanning can be interrupted, e.g. after selecting a device from the list.

1 Like

Wow alright I'll give this a shot, Thank you