Cannot parse text argument to "list from csv table" as CSV-formatted table

Hi everybody,
meanwhile I got my Wordpress installation on my host repaired (where I host the mysql.php from Taifun).

Now I get another error message:

Syntax Error: quote in unquoted cell
Cannot parse text argument to "list from csv table" as a CSV-formatted table.


Do I need to change my query or do I need to change the database table cells?? I would be happy for every suggestion.
Thanks in advance/opowoj

It really does help if you show the raw content of the responseContent, then we can see what is coming back from the query....

Hi Tim
thank you for the reply. What do you mean by raw content/how can I show the raw content?? I beg your pardon for my knowledge gaps...

Add temporarily a label and if get response code equals 200 then before calling your procedure display Table set that label to get response content. Then you can either post a screenshot of what label's shows or use Do it in label.text block and post the result here


Thank you Dora,

here is the post of a screenshot of the temp label content:

I add the line 41 above mentioned:

Line 41 : mysqli_set_charset($conn, "utf8");
$conn = mysqli_connect($servername, $username, $password, $dbname, $port, $socket);

Is there enough information provided there to inform you of your problem?

You do seem to be getting data returned, but there is a warning message about parameter 1 on line 41 of your mysql_neu.php file

See here:

in most examples they seem to be setting the charset AFTER making the connection (setting of $conn)

Hi Tim,
I put the charset after making the connection, and there is no longer a warning message.
Thanx a lot for the hint. I will remove the temporary label and see what happens.

Status (after moving the charset):

With the temporary label I get the query message and the wanted results on my smartphone and the "Cannot parse text argument to "list from csv table" as a CSV-formatted table." on my PC monitor.

Without the temporary label I just get the query message on the smartphone, but no query result and no error message

What happens if you try converting responseContent with list from csv table and just adding it to a variable (set as empty list to start with) instead of sending it on to the displaytable procedure. Do you get the same error? If you do, there is some issue with the content of your data that is breaking the csv table format.

Looking at the blocks you posted, you also appear to have a \n line return in your query. That is not normal....

I removed the \n line return, with the temp label: got the desired list, but runtime error

I removed the \n line return and the temp label and changed the procedure with a testResult list and got only the trying message, no other output

Before the query condition there is a ' then % and at the end there is a % and a '. I will check this without the '' what happens....

The last try brings an Error 400! Wrong SQL

Where is the "list from csv table" block ?

With that in place, do you get an error message ?
If you put global testResult to a label what is the output ?

The circled blocks are wrong, regardless of intent.
An empty list is not a text value.
Forcing a list into a text value without a CSV conversion block will leave you with [ ] or ( ) detritus, which clog further attempts at CSV to list conversion.

Meanwhile I managed the wanted output without warning or error message as a list. But in front of that list, I still get the message <meta charset= "utf-8">. My SQL database shows in the table structure instead "utf8_general_ci". I put that into the mysql.php program, but this had no effect. Any other idea?

Thanks for any answer/opowoj

show your blocks / query for this...

What message ?

I believe you should use as suggested "utf8"

Sorry for the lost mesage: "<meta charset = "utf-8">"

Here is a screenshot:


I add a screenshot of the output:

Is this back ?

Really do not know why <meta charset= "utf-8"> is being returned with your output. Worst case scenario, just remove it with a replacement block

there may be a non visible line return or two you need to remove as well - \n

Thank you Tim,