Cannot create file after App Inventor Update

I create .csv files in my app. Path looked like: [pic rel.] and it was working. Now I got error like: [pic 2 rel.].
Something changed after App Inventor update?
It's working on emulator (app companion) but not when installed on phone.


Use /storage/emulated/0/firetech_app/tel3 instead /Firetech_app


@wojti99 have you given permission to write to the private storage area/sdcard, and also created the private storage directory - you can do this with Taifun's File extension

(These permissions are normally already in place when using the companion)

I'm using the Taifun's File extension, too.
So, what should I do?

Doesn't work. I removed /tel3 because this was part of the file name.

I'm using the Taifun's File extension, too.
So, what should I do?

You have given the WRITE_EXTERNAL_STORAGE, but have you given the permision READ_EXTERNAL_STORAGE?

On my phone? I allowed every permision.


WRITE _EXTERNAL_STORAGE also gives the READ permission

Oh, sorry, glitch...

Okay, guys. What should I fix? Where is the root of error? Should I change the save file's path? Or this is App Inventor error after update?

you are using twice /storage/emulated/0...
this does not seem to make much sense...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

Please provide an example aia project that replicates the problem

This happened after first advice in this topic. Look at the first post.

your screenshot does not show, which component or extension and which method you are using
what about providing a more useful screenshot?


All the blocks. It worked few days ago...

Look. It is saving info to .csv file and saving photo (filename from part of the info).

From your last and previous posts, it seems you are mixing up the private area directory with directories on the sdcard. I put together these blocks and compiled an apk. It worked OK. I used the File extension.

If you want to use the private area, and it needs to be created, then check the documentation for the file extension and the file component:

Non-visible component for storing and retrieving files. Use this component to write or read files on the device. The default behavior is to write files to the private data directory associated with the app. The Companion writes files to /sdcard/AppInventor/data for easy debugging. If the file path starts with a slash ( / ), then the file is created relative to /sdcard . For example, writing a file to /myFile.txt will write the file in /sdcard/myFile.txt .

If the fileName does not start with a slash, it will be written in the program’s private data directory where it will not be accessible to other programs on the phone.

@wojti99 I apologize if you've given this information and I just missed it, but what version of Android is your phone running? The release last night will have changed behavior for Android 10, but knowing the Android version you're using can help us narrow down the issue.

My phone: Xiaomi Mi9T with the latest MIUI 12 - Android 10.