Cannot connect Iphone to App inventor and emulator will not install

Hi everyone,

About a couple of days ago, I was in my CSP class and we were programming an app and my teacher said that now we should connect our phones to app inventor. My teacher has sent us this app in which we can use app inventor on our phones, and it has worked perfectly fine in the past. But when I tried to connect it, it was just stuck at 50% for about 1 minute and said an error occurred. I thought nothing of it because I know that there might be some bugs, so I kept on trying and trying but it just wouldn't connect. I even deleted the app and tried to connect it but it just won't work. When I tried my other apps, they started to load but then stopped at 93-94% instead of the 50, but it still wouldn't load. My teacher told me to try and use the App Inventor Setup software (on windows)

I clicked the link and everything seemed to be working fine but when I tried connecting app inventor to the emulator, it just kept on trying to connect. I then deleted the emulator and tried to install it again, but when I try to install it again, it says an error occurred.

Output folder: C:\Program Files (x86)\AppInventor
Extract: LICENSE.txt
Extract: aiStarter.exe
Output folder: C:\Program Files (x86)\AppInventor\commands-for-appinventor
Can't write: C:\Program Files (x86)\AppInventor\commands-for-appinventor\AdbWinApi.dll

I have no idea what is going on. I did recently upgrade my wifi router but I don't think that is the problem. Could it be something to do with my computer? It has worked perfectly fine up until now, and I seem to be the only one with this issue. Thanks

1 Like

Is this the problem? :

Cannot connect


to App inventor

AppInventor is not iPhone compatible - yet, AppInventor for iOS is still being created and not yet ready. You will need to use an android phone or device.

1 Like

no so actually my teacher has this app where we can actually do the same thing on iphone as if it is on android. Its like in the beta test thing but it 100% worked before

1 Like

Hi - actually I have the same problem as you currently! I'm using an Android device for sure, and it turns out an error during testing the codes. I think there are two possibilities which suits you - one is that your device is not an Android device, or second is that there are too many coding at the same time - it cannot load with such amount - thus it said with an error. I think the second one has a higher chance as I have the same reason as this.

1 Like

But would that explain why the emulator isn't even able to download?

1 Like

And also, even the simple "I have a dream app" won't load. It is all very weird

1 Like

You are trying to develop a Project on your iPhone using an app you loaded on your iPhone? The issue may be this fancy app does not work with the latest version of App Inventor. Try to use a real Android device.

How did you try to connect? These are the Instructions for the emulator.

Did you load a Project using those instructions?

Did you install the emulator to the default location. You must use the default location.

When installing, dDid you set your PC to install the software using Admin ? The aiStarter has to be installed using Admin .

1 Like

Try using the newer version of the emulator. I'm a student personally, and my Computer Literacy teacher told me once that using the older version can cause many problems such as not able to download, very lag to use, etc. She recommends that we should use the newer version of it.

  1. Download BlueStacks from Microsoft Store (in case you love playing video games, you should be familiar with it)
  2. After finishing the process, download 'MIT APP COMPANION' from Google Play in BlueStacks.
  3. Then you can use it to test the games and projects you have done.
    (Only for Android Windows PC)

And I'm using that method, but it said an error. I hope this incident does not happen in your case.

1 Like

i tried using your method but for some reason when i press connect, it like wont start the connecting process

1 Like

Does anyone know what this means? It's the reason why my emulator isn't downloading

1 Like
  1. where do you see that message?
  2. Is it "the reason why my emulator isn't downloading?" Maybe' . It is possible your folders are write protected. Did you install the emulator to the default location. You must use the default location.

When installing, did you set your PC to install the software using Admin ? The aiStarter has to be installed using Admin .

Here is where the emulator installs

What do you see in that directory? Open the folder commands-for-appinventor; look for the AdbWinApi.dll . Is the dynamic link library there? Is that folder write protected?

1 Like

In the case of the iPhone version of the companion, make sure that your computer and your phone are connected to the same Wifi network. You won't be able to establish a connection if that's not the case and the assets will fail to transfer.

As for the installation issue with the emulator, make sure that you are running the installer with Administrator privileges. Given the error message is that it can't create the folders in Program Files that leads me to believe that you aren't running the installer as an admin.

1 Like

I had the same problem (can't write to adbwinapi.dll)

What I did was I want to delete the adb files and replace them with downloaded files to the folder. But adb.was in use. Soo I run adb.exe in the program files and it closed. I deconnect android device and reboot the computer. It worked for me.

1 Like

Ooo yeah. And I did some exceptions in the firewall for iastarter and adb.exe before rebooting.

But now I see only an appinventor setup was installed, but I can not find an exe to launch. Soo It is not a windows app inventor creator that I was thinking? It is maybe the emmulator...

This was the message I get.

1 Like

If the DLLs cannot be written, you likely have another copy of adb running in the background (it acts as a daemon). Typically the adb process is killed when you close the aiStarter program. You can do this via the Windows Task Manager. Once there isn't an adb.exe process, you should be able to proceed with the installation.