Building with Companion 2.62, I can download apk only, no install

Sometimes when building I can download, install and launch
Sometimes I can download only, I have to install manually from download folder

Do you use the companion app to scan the apk QR code ? This works well for me in initiating the installer.

Try to scan the QR code in Build -> APK using a regular QR scanner (not the companion). To install it, click on the result, which is a link, in the QR scanner.

Yes, I'm using Companion 2.62, sometimes it works well, sometimes no

I tried, same result, today I can only download the apk.

Did you enable downloading APKs for your browser? Try to open the APK. Without opening the APK, you cannot install it.

1 Like

I don't know how. I'm using Chrome, but as I said sometimes I have no problems

Try to watch this video. This is my teacher explaining how to download apps from App Inventor.

(Please don't share this video worldwide!)

(Note: App Inventor has some minor changes recently, the Generate QR code for APK is now just Android App APK.)