Bluetooth server wont connect to bluetooth MAC address

I'm trying to link two smartphones together with a bluetooth serial connection. When i tell it to connect it gives me this error, in addition to another message which i added.

I made sure to check if my bluetooth was on, and it was, so this leads me to believe that problem is with the address. Since it obviously tried to connect but couldn't. At first i tried isolating the device name from the bluetooth MAC address, since the name of the device isn't part of the address. But that gives me the same error as before. Can someone give me some suggestions for how to fix this?
FleetCommander.aia (7.1 KB)

did you try another device?
see also this example

If you are asking for help, I recommend you to make it as easy for others to be able to help you ...
You probably will get more feedback then...

which means in your case post a screenshot of your relevant blocks...

To download the aia file, upload it to App Inventor, open it, do some bug hunting for you, etc... this takes time, and most people will not do that...
Thank you.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

here are the blocks from my app
blocks (6)

![blocks (5)|690x163]

here are the blocks from my app
Most of this code was taken from another app which i downloaded.
both of the smartphones that im testing this on (Note 20 ultra and Tracfone ) use the android OS. The Tracfone is on android version 8.1.0, and the Note 20 is on android version 11. My intuition tells me that it shouldn't give me an error just because i'm using two different phones, since they both have the same operating system.

on the other device there is a bluetooth server listening to the connection attempt?

what happens, if you try the already mentioned example app?


Yes, there is a Bluetooth server listening on the other device. I assume that the Bluetooth server listens for connection attempts automatically, and that i don't need to add a timer which checks for that.

I'll have to test the example app on the Note 20 later, since its my teachers phone. Do you suspect that there may be a problem because the phones are on different versions or something else? I would think that the app would work without problems given how recent the operating systems of the devices are.