Bluetooth not showing "address and names" anymore

so this app has worked for a long time - I read about the BLUETOOTH_CONNECT & BLUETOOTH_SCAN deal recently.
If I trigger one or the other I get the same popup from both - the neardby devices deal.
if I accept that im still getting a blank list picker for address and names.

can someone give me a hand, this is something else - seemed to work right up until today by calling BLUETOOTH_CONNECT.

forgot to mention, it still works on companion, but my companion app is at least 6 month old.
my old apps work, but newly compiled downloads do not - which is scary, like its an MIT app inventor problem ...

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

thanks for always being so helpful. I reordered some things and now it works - after calling BLUETOOTH_CONNECT, I have this which fixed it. something where it didnt like how I was popping the permissions. quite the scare, it took me more attempts to rectify than id like to mention :smiley:
(especially because it worked on the companion app regardless, so it was compile and check for a couple hours)

bt connect

I do have another question related to the locationSensor, although minor -
on a new download it automatically pops the location permission prompt - is there a creative way to suppress that until programmatically called, or if I knew the permission name being called, I could trigger the BT prompts afterward?

Then you should start another thread, as it would be off topic for here


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.