Bluetooth not connecting; stuck at scanning/not scanning

Hello, I am attempting to connect MIT App Inventor to an EV3, or really Bluetooth device right now. I used the code which I found here:

I have clicked the "scan" button, but there appears to be no progress. It is evident that the button is working, for the label has changed to "Status: Scanning."

So the issue is that no devices are showing up in the list selector. Bluetooth is enabled on this device (iPhone with MIT App Inventor 2). I have also tried using a Chromebook with the MIT App Inventor 2 downloaded.

Please let me know how I should proceed. Thank you in advance!

Hello Suchir

Extensions (i.e. BLE) cannot be used for iPhone Apps unfortunately. What version of Bluetooth does your Chrome Book support?

Hello, I am not sure what version I have. I know that it's updated to the most recent things, so I assume the latest one (how would I check this?)

I have an android tablet with MIT's Companion downloaded on it. Would that work better to connect BLE?

I have also tried using JUST the "Bluetooth Client," on my iPhone, and that does not work either...

Thank you so much!

Since it's hardware, not software, you cannot assume anything, including whether it has Bluetooth at all. However, there is no guarantee that Chrome OS is going to be 100% compatible with your Android OS App - it can run some Apps but not others. To find out what you have got:
Open the Chrome Browser, new tab: and type-in: chrome://system - then hit Enter.

That would definitely be better to run your Android Apps. You will need to look-up your exact Tablet Model on the manufacturer's website to find out the Bluetooth version number.

App Inventor has a Lego Mindstorms 'component' with some controls for the EV3 (which, strangely, has been discontinued by Lego). So once you have established the Bluetooth version of your Tablet, take a look at that component.

I typed the chrome://system in, and I have a big table-like structure with labels on the left and values on the right. I'm not sure which one Bluetooth is, but "CHROMEOS_BLUETOOTH_FLOSS" says "disabled."

The tablet is still charging up, so I will let you know the model and Bluetooth version number once that happens. Thank you!


Looks like it is Fire HD 10 (7th generation). I was able to download the Google Play Store, and MIT's App Inventor. It looks like it is working, but it gives the names of devices in this format: "39:78:50:2A:47:1D null -50."
Is this normal (using BluetoothLE extension)? If not, should I try to use the normal Bluetooth Client?