Bluetooth list picker does not work with Samsung

I’m also curious if you’ve tried the App Inventor + IOT Basic Setup Guide and whether that shows any difference:

http://iot.appinventor.mit.edu/assets/tutorials/MIT_App_Inventor_Basic_Connection.pdf

friend, I have a samsung A-10, and my application with perfect bluetooth connection, use list selector in my blocks …
it is worth mentioning that command from samsung at 6 hawei and an arduino nano with its module and everything works Perfect.
I don’t know what is happening with your blocks since I haven’t had time to check your project with my samsung

I will send you my project tomorrow.
With the IOT basic setup guide I have not tested it, because the app should work on the real phone. I can test it tomorrow if I find some time to look how it works.

My friend, I have took a look at your bluetooth connection as I have said it some previous posts. You have made a normal Bluetooth connection app! But I have a BLE module with the BLE extension, this works a little different! It is not the same thing. The normal Bluetooth connection works, because you pair your device in the phone settings and the app can take them. A BLE module you can not pair!

si claro, se de que se trata BLE todos los sensores del simulador me envian metadatos GATT a mi samsung con esta conexion, utilice extenciones bluetoothLE … solo reflexiona:

  1. si tus HTC se conectan sin problema, tu aplicacion esta bien.
  2. revisaste lo que te dije de la configuracion en el samsung, “OPCIONES DEL DESARROLLADOR”-- “habilitar BLE”
    Por ultimo mi app no comunicaba con el modulo y habilite esta opcion en mi samsung, y se termino el problema, nose si tu samsung trae esta opcion y si ese sera el problema de tu conexion,

suerte…

Yes, I have looked in the option and allowed the BLE devices without names as you have suggested, but when I nornally turn the Bluetooth connection on and go in the Samsung Bluetooth connections, then I can see my module while scanning! The Samsung could find it, but my app could not! Because on the HTC my app works without any issues, I think tge Samsung phones have something that does not works with the BLE extension.

I have solved it - reset your Bluetooth… Setting > General Management > Reset > Reset Network Setting

Mine now works perfectly

1 Like

I will try it if my list will work! The main problem I have is, that the list viewer or list picker, both does not show/pop up! But thanks to let me know. If nothing is wrong with the app, I will give it a last try with that! It will delete all settings for WiFi, SIM and Bluetooth, so I will have to make them all new.

Did you or a member have tried it on a Samsung phone? Found any issues?

I have not still a solution for that problem. If anybody can help me?

I have played with the app and connected it with my BLE module and after disconnected. Some times I will get this error message:

Bad arguments to Text
The operation Text cannot accept the arguments: ,[nothing]

Then only the button “End Application” appears!
It is not very bad, but an issue with the app. Perhaps it is a problem, that occurs in the background on the Samsung phone and for that reason the list view for selecting the BLE device does not appears on the Samsung phone?
If someone with a newer Samsung phone has a Bluetooth BLE app created that works with the list viewer to select the device, I am also very happy to take the blocks into my app to try it if then it will work on the Samsung phone! My HTC is now almost broken. I really need a new phone and hope for some help…

Hi all,

I am creating app which communicate with ESP32. So in first everything was okey and app worked, but after installed new android 10 security patch 2020 02 update, suddenly app won’t communicate at all. I am using Oneplus 6 phone. So I suspect that new security patch does’t allow to communicate with BLE extension 20181124 version. The older phone with older android can communicate without any problems.
I guess you have the same problem.

That is perhaps possible, but if that is really the problem, I can not fix them until the extension will be updated.

Ewpatton give direction to github with java files. So I sneak in and try to find something. And in BluetoothLE.java file, 73 line where you can fine userpermissions, “@UsesPermissions({ BLUETOOTH, BLUETOOTH_ADMIN, ACCESS_COARSE_LOCATION })”

Access_coarse_location is good for ANDROID 9 and lower, and for ANDROID 10 you need declare “ACCESS_FINE_LOCATION”. I do not know it’s a big deal, but when you developing in android studio in manifest you must declare that.
https://developer.android.com/guide/topics/connectivity/bluetooth-le#java

Maybe I can change that by myself, but I do not know how to everything put in AIX format. Afcorse, you can open AIX file with simple winRAR or 7-zip and extract all java files.

That is a great information! Thank you very much!
I have tried to open the .aix file with 7-zip, but there are only .class files in the .jar files. It has two .jar files. But no .java files in there. One of them is called classes.jar and the other is AndroidRuntime.jar.

If one of the MIT members will fix it for future use would be great! Or if you, Justinas_Krauleidis, can make a .aix file to try it.

Hi,
I have the same problem and not being a ITer, all this info is too difficult for me.

My solution is maybe too easy but it works for me on a Samsung S8.
I just allowed the phone to communicate with other devices in the Bluetooth menu, and then the listpicker in my own program works fine and recognizes my ESP32 board.

Hi,
I had the same problem with my new Samsung Galaxy XCOVER 4S.

My app working with BLE module (HM-10) worked fine with Samsung Galaxy S7, S9+, Sony Xperia Z3, Z5 Compact.

XCOVER 4S was problem.
After reading this thread, I just tried to check if location feature in setting is enabled. It wasn't. Turning it on lead to devices appear in list:

Settings -> Location -> Turn on (slider)

After that, I got list of BLE devices in my AI2 app.

I was testing the app on new phone so I newer enabled the location before.

The Xperia Z3 (Android 6.0.1) behaves the same way - it just came to me with the location service already turned on in settings. If I disable the location, I am unble to list devices...

I hope this helps you.

I've got the same issue with my Note 9. Android 10, latest BLE extension and AI2. Doesn't show the list of devices. I've tried everything I have managed to find as a suggestion. I think somethings broken from a recent update.

Dear all,
There's an upgrade of the BLE extension dated July 2020. With this update everything worked fine. Checkout this thread, there'll find the link: No devices found during BLE scan on android 10
BR
Frank

That are great news! I will try it out! Hope to find some time for changing the extension soon in my apps to try it...