Bluetooth connectivity issue: Mobile screen goes black when searching for BT devices

"Good evening, I am currently having an issue with Bluetooth. When I activate the device search in an application, the mobile screen goes black and no list appears. The same application, which worked before, now has this problem when I reinstall it with App Inventor. This happens now with all the applications I install on different mobile devices. Can someone tell me what's going on? Thank you."

Is your device search set to display a listpicker ?

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Here is a screenshot of the blocks. Thank you for your quick response!

Yes, of course.

Sorry, these are not the blocks. I will upload the correct ones now.

Mobile screen goes black when searching for BT devices

are you saying "when clicking the listpicker"? which means, the AddressesAndNames property returns an empty list... is Bluetooth enabled?

btw. you have 2 minor "errors" in your blocks...

  1. to connect to a device usually you use an if statement like this
if BluetoothClient.Connect Listpicker.Selection
then "successfully connected" and start the timer to receive something
else "not connected"
  1. it does not make sense to check inside the timer, if the bluetooth client still is connected, because once it is connected that property stays connected and will never change to not connected anymore, see also


Regarding your question, bluetooth is enabled and when I press the listpicker, no list of Bluetooth devices is shown, the screen just goes black. The curious thing is that this does not happen with other previously installed applications with the same connection code.
I made some changes trying to follow your advice, but I am still experiencing the same issue.
Thanks in advance

This the listpicker you are seeing (black screen) with no devices found. You should be able to Backpress out of it.

I'm sorry, but I didn't quite understand what you are asking me. When running other App Inventor apps, the list of Bluetooth devices does appear.

For some reason, the AddreasesAndNames property does not show any bluetooth devices...
What happens, if you try a little bit later again?

Which device and Android version are you using for your tests? Did you try another device?

The second clock you can remove completely as it does not make sense...


Do you have the appropriate permissions granted in the app? In the initialize blocks you should ask for proper bluetooth and maybe location permissions.

Exactly the same.

Which device and Android version are you using for your tests? Did you try another device?
I have tried it on different devices and different versions of Android, both old and current ones, and nothing changes, the Bluetooth addresses are not appearing.

I am also experiencing this issue with applications that previously worked and that now, when reinstalled, present the same problem. In the video I am attaching, you can see how an application that was previously installed works perfectly, but when I reinstall it from App Inventor, it no longer works properly. I have also checked the permissions, and they have the same permissions. Something has definitely changed, and I don't know what it is.

Hello GJover

Given that your App(s) worked before and now you are working on it again, what have you changed before reporting this issue?

Have you changed the Theme? Have you changed the colour of the List Picker text? I notice that there are a lot of errors in your code....

Can you list the device Make/Models you have tested, together with the Android Version and Bluetooth Version please.

Finally - if you run this project:

BT_Basic_Setup_Receive_two_vals.aia (7.7 KB)

.....are devices found?

When I installed your application and tried to search for BT devices, it generated an error due to lack of permissions, but after granting them, it worked well!!
Later on, I reset the permissions for my applications, and they started working again. I really don't know why it worked now and not before since I had already checked the permissions. I suppose I must have done something else but I don,t know what!.
On the other hand, my applications still don't work properly on a GT-N511 tablet with an older Android 4.4.2 system, even though permissions have been granted. It's a complete mystery. Anyway, thank you very much for your help.

It's possible that your App is using a function or extension that is not compatible with Android 4.4.2 (10 years old).

Aynı sorunu ben de yaşadım, önceden Samsung Galaxy Tab3 tablet ile çalışan programımı Galaxy A7 ye yükleyince bu problemi yaşamaya başladım. nasıl çözülecek? lütfen yardım edin. Ben de Samsung android sürümüyle alakalı olduğunu düşünüyorum. (I had the same problem, I started having this problem when I installed my program that used to work with the Samsung Galaxy Tab3 tablet on the Galaxy A7. How will it be resolved? please help me. I also think it has to do with the Samsung android version.)

What is the exact Android version on both of your Samsung devices Abdurrahman?

Hi, I'm experiencing the very same problem (the listpicker lists no devices ... My smartphone has Android 12 and I have paired it previously with the HC-05 module

I send you a screenshot of my blocks, it's a very basic program, as you can see: