Bluetooth app made with mit app inventor not working

Hi,I have made a Bluetooth app to send data to an Arduino uno via bluetooth,but every time I click to send data I receive a square on the serial monitor of the Arduino,need help ASAP plz

Welcome to our community. Please take a screenshot of your relevant blocks and upload it here, or else we cannot help you.


Ok here is it:

I use these blocks multiple times to make multiple buttons and i change the letter sent to something else

Hello Youssef

Your Blocks look OK - an issue with the Ardunio Sketch (Script) possibly?

No,it is not in the Arduino is it works fine with other Bluetooth apps and terminals so I think there is something wrong with the encoding or something

Upload the sketch so we can compare it to the .aia file?

Well, App Inventor defaults to UTF-8 and Arduino defaults to ASCII, but for the first 128 characters they are the same bytes. So if you haven't changed the character encoding in App Inventor, the Sketch code is a suspect in the mystery.

There is one other thing - you must ensure that your phone has'Location' switched on......

1 Like

ok i will try with location on and anwser you asap

@ChrisWard I Turned The Location on But Still The Same Result

@Chrisward Making The Encoding in The App ASCII Solved it Thanks For Letting Me Know About The Encoding Used

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.