Blank screen when emulator starts (LINUX)

Hello everybody!

We have this problem using App Inventor on Linux. First we run the aiStarter and then we run the emulator from the browser to be able to run the application. When the emulator finishes loading, the developed application does not appear, but a blank screen appears. The aiStarter displays the following error on the console:

emulator: ERROR: Could not load OpenGLES emulation library: cannot open shared object file: No such file or directory
emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.

Does anyone else have this problem?

Thanks a lot!

Hello David

The OpenGL lib can't be found but it's not essential - did the emulator not display your App anyway?

It might be that the App is too large or uses code the emulator does not understand - this can happen when you use extensions.

However, if you have a smartphone, it's far better to run the App Inventor Companion on it and observe your App live in what is going to be it's "real world" rather than using an Emulator.

Hi Chris! Thank you for replying!

The emulator always fails to show the app, just a blank screen. We are not using any extension.

The same error occurs even with the initial sample apps, when running the emulator the white screen always appears at the end after loading.

The thing is that we can't use the AI2 Companion App because we don't have a Wi-Fi connection in the class, we only have wired connection :frowning:

No one has this problem? Thanks!

I can see from your Screenshot that the emulator is the early version - it might be so because you are using Linux, or it might be that you have downloaded the wrong one.

Concerning WiFi, you can use a USB cable between PC and Smartphone to run the Companion - a lot of Users do, for various reasons.

I'm going to assign your Topic to the MIT expert on the Emulators.

We are having the same issue today. Our emulator ends up being blank like you said, even with the new emulator.

I have seen this. I'm going to do a review of emulator reports soon.

If you can use the 64-bit emulator available for download, please try that. The 32-bit version is deprecated.

I do have similar problems in my classroom. I've been using the emulator with linux computers for some classes over the last years without problems (other than waiting for the internal app updates).

Two weeks ago I tried to start another class on AppInventor using the emulator. I was not able to get it running using ubuntu 22.04 . The emulator starts up, then the companion app starts but it ends with a white screen an some error message.

I tried to do another reinstall today. But now the download link ( is broken.

The link is broken (404), confirmed.

Oops. I broke the link when I "upgraded" (actually, replaced with a new server), yesterday. I'll fix it shortly and post here when ready.

1 Like

P.S A blank screen in the emulator usually means that you are using a component that isn't implemented in the ancient emulator (Froyo). If you can use "adb" to do an "adb logcat" you can usually see the culprit.

The linux emulator download links should work again... Sorry for the bother.


You might like to try a 3rd Party Emulator:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.