Automatic sending of SMS with Galaxy A10 DENIED!

for a long time I have used an APP created by me with APPINVENTOR capable of AUTOMATICALLY sending SMS with a pre-established text to numbers already entered in the app on different days and at different times! for years this APP has worked PERFECTLY !!! but a few days ago I bought a new smartphone (samsung Galaxy A10 with Android 9) and I found that text messages are NOT sent automatically with this device! you must always send manually! but doing this cancels all the work done !! because if I have to do it manually it no longer makes sense to use my APP. how did this happen? is it a problem of APP inventor or new Android OS? is there a solution ?? or do I have to cancel and throw my job away?
thanks a lot for any info!

Hello @PiERO

Google Play Store had a policy change that forced us to remove the SMS and Phone Call permissions from our published companion. There are new blocks, SendMessageDirect and MakePhoneCallDirect that you can use to restore the functionality, but you need the companion from App Inventor (see Help > Companion Information), not the one from Google.

More details here:


1 Like

thanks a lot for the info!
I have replaced all the SendMessage blocks in my app with SendMessageDirect but it still doesn’t work!
now when I try to send I see a message “allow to send SMS?” and even if I choose “allow” the message is not sent! what am I doing wrong?
are there any video tutorials or simple guides where I can see how to use the NEW Texting component?
thanks again for the help


perfect! wonderful

I don't understand what the "MIT AI2 Companion" is for
I have been using it for a long time to preview my works but what does it have to do with sending SMS?
Sorry but I'm very confused! I can't understand well ...

Google changed policies regarding those permissions recently. They don't allow apps in Play Store that request those permissions AND that are not made with that purpose (i.e.: messaging apps, phone call history apps, etc.).
This forbids any kind of app to request that permission if it does not serve for such purpose.

MIT AI2 Companion allows you to live test your app without exporting your app. But to make it work, it has to ask for the same permissions as your app would need. As a result, we have these two apps in the development process:

  • Your app: app that sends SMS.
    Permission: read and send SMS's.

  • MIT AI2 Companion: app that allows you to test your app without downloading it.
    Permission inherited from your app: read and send SMS's.

Problem: Google does not allow AI2 Companion to request the read and send SMS's permission, as AI2 Companion is not strictly designed for such purpose.

What Evan means here is that there are two variants of the MIT AI2 Companion: the one in Google (Play Store) and the one hosted in the MIT AI2 server.
If you wish to fully test your app, including using the restricted permissions, you will need to download this Companion from their server, as it includes the forbidden permissions in Google Play.

Not really sure about this issue, but maybe this could be the problem? That somehow the application is not sending the re-routing request properly.

When you use Texting.SendMessage, the phone will now route the message to the phones normal text message sending application. Similarly for Phone.MakePhoneCall.

Taken from Change to Googles policy for the Play Store may require changes to App Inventor apps


Hi all. I am having this problem too. I tried using SendMessageDirect but get the permission block on my Note9. I tried running the app via the MIT AI2 Companion and downloading/installing the APK. Is there more news on fixing this or should I move to a different dev environment?

Could you expand on what exactly you mean by the "permission block" (a screenshot may be in order)? If you're referring to the dialog where Android prompts you for permission to allow your app to send text messages, you can't get around that showing the first time. Once you've granted permission, it should send text messages without needing to open the Messages app. Note that this will never work with the MIT AI2 Companion available through Google Play because their policies required us to remove it, but as long as you install the version using the instructions above it should work.

For reference, if the version number in the companion ends in a u, e.g., 2.56u, then it should support using the SendMessageDirect block. If the version number doesn't end in a u, e.g., 2.56, then the block won't work.

Thanks for the reply! To resolve, I changed the code block to use SendMessageDirect and then downloaded the APK via QR code. Once installed, I went into System Settings then to App Permissions and gave the app permissions to SMS. It works now.

As I understand, the AI2 app will never be able to directly send while in testing.

This is not true. The AI2 companion installed from the Play Store will never be able to do this (by Google policy, there isn't a technical limitation). We publish an alternative version through the AI2 website, which you can get by going to Help menu and selecting "Companion Information". This will give you a QR code you scan to install the version with the extra permissions.

1 Like

I'm trying to do this but it says: invaled link, do I need to do something different now to dowload the Companion through the AI2 website?

Hi @ewpatton, I'm looking now but I can't seem to find the Campnion on the AI2 website.


AI2 > Help > Companion Information