Audio recording doesn’t work

Hi, the audio recording stopped working. It doesn’t store/save the recorded file.

The message asking for permission to use the microphone shows up normally, but the 2nd message asking for permission to access phone’s storage doesn’t show up. After giving the app storage access permission manually, from app’s settings, still doesn’t save the recorded file.

I had this issue in the past, searched the forum and Google for solutions and tried them all, nothing changed until a new update for app inventor was released and everything was back to normal, apps were recording and saving audio without any issues.

The current problem started with the latest update for ai2.test.appinventor so I switched to main server, now the main website is having the same problem. The website code.appinventor doesn’t compile the apps to .aab which is required to publish apps on Google play.

Any ideas how to solve this issue or when to expect a new update that hopefully would solve this problem?

Thank you,

This is weird, since the new nb188 update just dropped, hoping to fix all the issues with the SoundRecorder. Is there any error message that pops up?

1 Like

Thank you. There are no error messages, everything looks normal until after installing the apps.

And just to test things out, I try several of the installed apps on my phone, works normally. Then I go to app inventor and compile them again, without any changes in the code, and suddenly they suffer from the same problem like the new apps.

Now I’ll have to unpublish my new app because I had no idea that the issue is moved to main server, instead of fixing it on the test server. My mistake because I didn’t test everything while I knew that app inventor gets this bug from time to time.

And can’t update any of my apps or they will lose this function after compiling them. Have to wait for a new update for app inventor that hopefully would fix this issue.

To get specific advice, please post your Blocks. It is impossible to know whether what you experience is a bug or an issue related to your Android version or

where you have been storing previously. You may have to store your file in a different location than you expect. We don't know because you have not shared your Android version, your Blocks and confirm whether you are using the latest release of App Inventor (nb188) on the main server .

1 Like

With all due respect, I researched all possible solutions. This is not the first time this problem occurs.

If it was a problem with android version, coding or anything else.. it wouldn’t have been solved when new update is released, then back again when another update is released. My conclusion and maybe I’m wrong.. they simply copied the current update with that bug from the test server to the main server.

Possible causes that I tried to work on : android version - permission settings issue -,blocks and code - using extensions to find a away around it.. and many more!

You can try it yourself and create a simple two-buttons recorder. You don’t have to, but it may help you if you’re planning to use that function in your apps.

if you do not provide a Blocks example, we can not help you. You have an issue and part of the problem might be moving from the test server to the production server without updating your Companion.

We can test lots of things but please make this easy and share your code or a small example so we know we are testing the correct situation. Thank you.

1 Like

Thank you, I didn’t move from one server to another. I’m updating the apps from where they were originally created. The main server. But I’m also working on the test server that’s how I’ve seen the issue moves from one server to another.

This is the code I’m using :

Appreciate your kind help.

This is most likely the problem Michael


You are attempting to store in My Documents. It is an issue for all users but especially an issue
it appears for apps running on Android 11+ .

You need some code like

Don't do that. Use only the main server now that nb188 is released.


Thank you very much for everyone's help. Really appreciated.

Problem solved by using "FileTools" Extension :

Used the extension to create a new directory for the app, instead of saving files at "My Documents/Recordings", and included asking users for permission to store the recorded file, instead of the automated permission message generated by android's system.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.