Application installed list

How could i obtain a list of all installed apps on my device ?

1 Like

yes, the packagemanager extension is able to do it


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

It's exactly what i was lookinf for...thank you Taifun.
but i have no icon !

use the AskForPermission method from the screen drawer and ask for android.permission.WRITE_EXTERNAL_STORAGE before using the extension


ok I did it.
then directory Picture/.Package is created with icon in it

but icon doesn't appears in app..i think there is a problem affecting a picture to an image if it is not in app directory. i have the same trouble with my app.

And when i start your app an other time nothing happend: it seems waiting for permisson but it have already it !

what happens, if you use the example project and add the AskForPermisison block there?
does it work in the companion app and/or after building the app?
which Android version are you using for your tests?


I'm using your exemple project.
i succeded to solve problem of image copying it it app directory. then i can see it.

for the second problem, i tested it after works well the first time, but if i stop app and lanch it again, nothing happen.
because you talked about it, i tried it with companion too and then nothing...

about my Android version:

Read this long thread, maybe you will get some helpful hints there ...

ok so after several tests, this is my result

with i didn't succed to have icons (with or witout write permission)

with I can have icons only with write permission. but i have to copy icon's file in app directory to be able to display it

If permission is given during first app lanch, PermissionGranted is not call again when you lanch app i used a variable in order to not call GetPackage twice.

this works fine.

I hope it will help..
thanks to Taifun and Anke

packagemanager.aia (57.4 KB)

I found a bug in the extension and fixed it meanwhile... the icon was not extracted for all packages...
also I moved the default directory to a subdirectory of the ASD, which now is /storage/emulated/0/Android/data/<packageName>/files/Packages.
Now no permissions are required anymore.

Please download the latest version 2 and try again


1 Like

Thanks for reporting the bug.
But, what happens when you use SetIcon method?
It should work because it does not saves bitmap anywhere.

nothing happens : no icon displayed on image...

I tested it and it works well.
i'd like to do the same in my extension, but i don't succed to save file in

only in /0/Android/data/<packageName>/Cache/ where Image block can't read image...
which code do you use ?

Well..I have to correct it : your aia file works perfectly, but if i download aix and use it with the same blocks code, it doesn't works.(dir not created) it seems you have a problem in aix link...

if i download aix and update it in your aia, it return:

Enable the permission in app's settings

but it doesn't ask for permission during installation !

You have to use screen1. ask for permission block.

I see nothing about it here !

and i don't understand, because i didn't change nothing in bloks code, just update extension...

and Taifun said [quote="Taifun, post:11, topic:20837"]
Now no permissions are required anymore.

That's a link.

I don't know that because I haven't used the extension.
I agree @Taifun said no more permissions required, but try asking for one and see.