Appinventor Tools when running on M1 Mac

Hi! So I recently tried to get app inventor working on Mac M1 by using the comment that was marked as a solution in this post. The only error I'm getting is it cant find files used by app inventor such as "kill-emulator" or "run-emulator". Does anyone know where I can acquire these files?

Thanks in advance.

Actually, the easier thing to do if you want to run an emulator on an M1 Mac is to install the published App Inventor tools package and run an emulator via Android Studio. aiStarter will use the existing emulator rather than start a new one. This way, all of the files are in the right locations.

Yeah, I am having problems with android studio right now, so this is much easier for me. Do you know where they might be?

If you've installed our support tools package, they will all be in a folder at /Applications/AppInventor/commands-for-Appinventor. It's just that the emulator included in that bundle is for Intel Macs, not M1 Macs, which is why you will need to be able to run the Android Studio emulator to compensate. I think Android Studio should automatically select the M1 emulator package when it installs. However, I don't have an M1 Mac so I cannot verify that.

I got android studio to work! However, when I run the emulator, and then also aiStarter, the emulator crashes within 10 seconds: ERROR | Unable to connect to adb daemon on port: 5037. Is the main error I believe. Not sure what to do about this, any ideas?

What I've been doing (Might have misunderstood your instructions):

  • Run the Emulator through android studio
  • Run aiStarter
  • crash occurs

Which thing is crashing, specifically? There are multiple moving parts here and they all need to work together. An immediate next step might be to copy the version of adb from ~/Library/Android/sdk/platform-tools to /Applications/AppInventor/from-Android-SDK/platform-tools so that they are the same, since the adb protocol can differ between versions.

Specifically the Emulator Crashes, it just closes with the error I mentioned above. I think it might be related to the fact that App Inventor is version 39 and my emulator is version 41. I downgraded my ADB however to version 39.

@dyjkim Since you have an M1 Mac, can you try the procedure I outlined and see if you can replicate the crash reported by @Teo_Welton ?

Was there any update on this?

I actually succeed on making the emulator work. Can you describe which part you got stuck on?

Im not entirely sure. I started the emulator through android studio then I started aiStarter through the python file as described in the original post (there was a link). However, when both are running at the same time it crashes the emulator and I cant launch the app. If you could provide your steps that might also help

Funny, since I went through the same step. I think you already mentioned that you used an updated android studio, can you make sure that aiStarter is also updated also?