Appinventor does not load my .aia file

I've been trying to upload my .aia file for about two hours and get this answer, do you know what's going on?
Server error: could not upload project. Please try again later!

The file size is just 12.30 MB.
Up until 15 minutes ago he had loaded it normally without any problems.

I've been waiting as long as I could and I'm still waiting, but nothing to do does not load the file.

refresh your AppInventor tab / refresh your browser / restart your browser / restart your computer

i've faced such problem sometimes you need to backup your projects specially if they are big sized and delete them from trash then import them it will work , this happens if you are using app inventor offline version

it seems it has total size of all projects around 100 mb or maybe less when you can no longer import any aia project !

Thanks TImal2, I did more I re-installed the whole system, but nothing done.
Now I'll try to follow Don_Ammar's other advice,
I ask to be clearer. because I use appinvntor online and not offline.

1 Like

Nothing to do, it seems that for the moment I have lost any changes to the project, I can't upload it again, it always gives me the same result.
Luckily I resumed the project from 4 days ago, this loaded it without problems.
4 days of work wasted.
I hope I can recover and remember what I had done.
However, I learned another lesson, also save an image copy of all the blocks, always.
Thanks everyone for your help, good continuation.

If you can share your aia project (that won't upload) on google drive, someone here might take a look at it, see if it is corrupted, or if it loads on their setup....

Did you try loading to the server?
It has a longer attention span.

1 Like

I have now eliminated it, unfortunately.
What I have taken works perfectly, so I will go on with this, in the event that the problem occurs again I will be able to tell you.
Thank you all.

Sorry ABC explains better what I should have done?

well my advice won't help because you are using the online version

but you can use this one and try to import your project to it , might help.

I hope I never have the same problem again but if it does, I will try it.

I finally found out why my app's .aia file was no longer loaded.
I had entered, 300 files in the Media section - divided into audio files, images and .csv.
Rebuilding the project, I realized it wasn't loading for that reason.
To be sure I deleted all the files from the "media" section and the .aia was loaded, so I solved the problem by inserting the files when the project is finished.
I hope that the Appinventor programmers allow their code to be able to insert even more files in the mentioned section.

To reply also to "Don_Ammar", I tried it but also in the local appinventor, it didn't load it, for the same reason.

Ho dimenticato un'ulteriore problema: se tentavo di salvarlo effettuando una copia ma mantenendo lo stesso nome del pacchetto mi dava errore, inviando questo messaggio"(Server error: could not copy project. Please try again later!)
Mentre se cambio nome al progetto esempio: Angelo_Da_Copia" in "Mario_Pip" allora effettua la copia regolarmente con tutti i 300 file nella sezione media.

I also think I understand the reason for this problem.

When I create my app, the Appinventor server creates a folder assigning me a finite space, after which, if the App has too many files, it can no longer process the package.

So I think, but it's just my guess, that it will be enough to increase the space dedicated to the package and everything should work out.
In fact, if I change the name to the App, it creates another folder and the space becomes usable again, but if I try to make a copy with the same name again by adding only: "Name_Copy", the space of the new folder on the server being full again, he will not be able to create the copy, but he will need another name and create a new folder in a circle that will repeat itself over and over again.

So as written, just increase the space for each package on the server and I think the problem will be solved.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.