App works fine with my phone but not at all with another one, or tablet

After much help from forum experts, I got my Peekle app working perfectly. I have a Note 9 with Android 10.

I loaded the .apk onto my old Note 4 with Android 5 but it does not initialise data into the app for it to function.

The same happens with a tablet (a cheap Mediatek eBay purchase) running Android 8.1.

I’ve spent ages trying various strategies in an attempt to identify and cure the problem - no luck.

I finally reduced things to the simplest possible test (see attached blocks). Note 9 works and returns data, but Note 4 and tablet don’t even return the error message - there’s no response at all to the button press.

This means I’m unable to share the app with other people until the problem is solved. I’ve run out of ideas now - can anyone please suggest what the solution might be? Many thanks.

blocks (1)

Have you tried a sample app accessing the tinywebDB from the two devices that are not working - e.g. a simple save and get tag app, separate from your Peekle one?

1 Like

Thanks once more for helping. :grin: Blocks show the simple app you suggested - built using Companion on the tablet I mentioned.
Again, no response from the tablet, but worked as it should on the Note 9.
Hard to tell whether data hasn’t saved in the first place, or whether problem is retrieval.
Difficult to accept that’s it’s basic device incompatibility, but what else could it be?

blocks (3)

Are you absolutely sure that you have enabled Internet connection on your tablet?

Thanks for your interest. I tried again to be completely sure - with the same result!

This is a big mystery!

For me, it works on all of my test devices (Android 5, …, 10).

Especially on a Note 3 (Android 5.0).

That’s even crazier! :astonished:

So check the network connection again. Open a website …

Yep, YouTube opens no problem. I do have a reliable internet connection - 3MBs/Sec. I’m really grateful for your persistence - thanks so much.

Did you test with Companion or APK?

… and try also to enable LTE / 4G.

Sorry for delay - I thought I’d try same thing using the default URL
Still no response.
I’m doing all this live online using Companion. I’m assuming that building and installing an apk would give just the same result?
I’ll do some research on LTE and see if I can incorporate it into my setup. Thanks again.

Ok, try this:


Do you get a response.

Which php version are you using, is it Juan’s one page php or the storevalue/getvalue version ?

1 Like

I already tried that - still nothing happens.

If I remember correctly it was the one he suggested when helping in my original post - I’ll check and report back. Thanks.

Not sure of which of those two it was. I took it from the php code he posted on this page:

Try this test APK:

@TIMAI2 @Anke
A small breakthrough. When the service URL is set to the test app at last works on the tablet. Does seem to point to a disagreement with Juan’s .php tinywebdb file.
Please excuse me if I break off now - I’ve been at this for nearly 8 hours solid and need a rest!
Thanks to both, and will resume later. Barry