App not responding close or wait

Hello, I'm new here and English is not my native language. I have already read many of the posts in your lecture and am delighted with the helpfulness and contributions in contrast to other forums that I consume. I created a microcontroller project that I control with an app. Thanks to the forum posts I was able to create the app and it works. Except for one small thing: sporadically (it doesn't always happen) a message appears in the app "App is not responding, stop or wait". I have already found a post: "App not responding close or wait - Radio streaming app - MIT App Inventor Help - MIT App Inventor Community". But I can't find a solution that fits my app. Except for the vertical slider, I don't use any extensions, just standard objects. So I just can't explain it. If you press "wait" the app continues to work. So it's not like it's breaking off. It looks like the app has nothing to do. I also emptied app cash. Could it have something to do with the many updates to the app (programming, installing, testing, etc.)? I thank you in advance for your feedback.

Probably you can find out more if you use logcat


Thanks for the quick answer and the link. That would be another new thing I have to learn. I don't even know what I have to download. There are 3 points under the link provided which are broken down further. I'll take a look at this. I was afraid that the only way to get to the bottom of this problem is to do a very detailed problem search (logs and so on). However, as a beginner, i feel that this is a bit “too” much for me at the moment (Arduino, C++, AI2, etc.). But I will give it a try by the weekend at the latest :upside_down_face:

I managed this with logcat. Not as difficult as expected. However, the problem no longer occurred. If it happens again I'll take a closer look. I have another question. I would probably have to start a new topic. I'm unsure because I have little to no experience with forums. I'm trying to load the Bluetooth devices into a spinner. I don't like the list picker. But that makes it work. I just can't get it done with the spinner. Somehow it just doesn't work. Not even the label is updated with the address text. I'm desperate. I've probably tried 4 different approaches without success. I have attached a simplified version. If you have a tip that would be great!

Hi TIMAI2, thank you very much for your answer. I can hardly believe it. Your tip about setting the spinner to 1/1 gave me the idea. I set the spinner to invisible. Since I was able to open the popup and everything was displayed correctly, I think it works like that. But apparently there are problems internally in this way. I'm shocked: "not visible" doesn't mean "inactive". Anyway, I have now set the spinner to visible and it works with my blocks. I'll still optimize it. For example, I think the additional entry “Close Menu” is a great idea. I'll also look at the link you posted again. Thank you very much again. I tried it for hours today and was close to tears...

Glad it helped.

The search function and the FAQ section on the community can be very useful...