"App not installed"

Good morning,

Apologies, I know this is a recurrent issue that many users face, I have read as many of the related forum posts I could find, I have read Chris Wards checklist here; ProfessorCad: Tips & Tricks and addressed as many as I understand!

My app is designed to connect via bluetooth to an arduino that monitors 0-5v analog inputs from automotive sensors, pulls the data across and using some mathmatics, convert the 0-1023 signal sent from the arduino to a number that relates to the source sensor (temperature, Air to fuel ratio and vacuum/boost pressure).

I havent been able to confirm whether it works fully yet as am waiting on a replacement bluetooth module (HC-05) as mine is faulty. However in the meantime, I wanted to upload to my phone to test without using companion. Sadly when trying to install it reports "app not installed".

Please see attached blocks, app aia and arduino code if needed. I am new to this so, thank you in advance.

RX7Dashv2.aia (1.9 MB)

Arduino_dials.ino (1.7 KB)

Not installed but built okay?
Try removing the Screen1 icon.

Thank you for the quick reply. I have done that and the same error occurs. The original icon was 96x96 and uncompressed PNG as the check list stated.

Any other suggestions greatly received. Thank you.

To cover the case where this is a conflict with something left over from a previous install,

  • check if you have space on the device for a new install, and
  • change the app name in Screen1 to install as an entirely new app
1 Like

Thank you again, I can confirm I have 27gb free space on my phone's storage, I have changed "appname" on screen1 to "Install as an entirely new app", and I get the same error message.

I downloaded and installed your app, after removing the space from the app name in Screen1.

The app installed okay, after I told my phone to override its protection against non-Play Store apps.

That Slider animation in Screen1 with Clock1's Timer set to 1 ms was a strong disincentive to further testing, bogging my phone down until I managed to deinstall the app.


I never got to the Index screen, because Thumb positions are non-integral and Slider1 probably shot past that 100 value without an exact match.

It would have been safer to use a Greater than or equal test, or simply to have skipped that nonsense and started the other screen immediately.

I saw no extensions in your two screens, so I expected no residue from a deinstall.

My current suspicions are of your phone not presenting you with the dialogs where you could override its install protections.

Thank you ABG, disabling play protect has worked for me too.

I can move to debugging now, and start with removing the splash screen!

How to Splash:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.