App Inventor Won't Load

"This webpage was reloaded because a problem occurred." and "A problem repeatedly occurred on https: app inventor page show up on a page when these 3 kids try logging into app inventor. I have 90 students and 3 kids keep getting these same messages now and cannot log into app inventor. We are using ipads if that matters. I tried seeing if anyone else had these issues but am not finding a work around.

App Inventor is accessed at Since your message references https:, it may be that they're getting the error for specifying the wrong protocol.

Hmmm I will check that!

My mistake on my post, it is not https.

Are these school issued devices, or personal devices? For the accounts, are they the students' personal accounts or school issued accounts? If the former, are the students under 13 and therefore managed under a Google family account?

These are all school issued ipads. Only 3 kids aren't working...the kicker is that they worked just fine for most of the semester. We have tried loggin in/off, powering on/off the ipads, loggin on/off ipad accounts. It seems their accounts are stuck in a loop (if you can understand that) where they cannot login anymore.

Are they able to log in from a different iPad, or from a computer? It would be good to determine if it's an issue with the specific device or the specific students.

This URL will only get the students as far as their Project Lists, without trying to load any bloated Project:

It is against our schools policy to have them use other kids devices, so I cant have them try on a different ipad. It started with one, now we are up to 4 kids have the same error. Could it be a version of IOS error?

Try reinstalling App Inventor Companion. Try updating the iPad. Try rebooting. Try clearing the cache.

Ok, I tried my own device (Samsung Tablet) loaded with her app inventor account. The app loaded up just fine.

Then it might be something wrong with the iPad.

So it seems like it is a possible issue with the iPads. When one device works and one doesn't, are they running the exact same iOS version?

Yep. Exact same os, at school on same network. Everything is identical, its bizarre

And the school doesn't run two networks? We've seen this type of thing when there's a network for teachers and a network for students, where the latter is more locked down, so teachers get access and students can't. Is there a guest network where the handful of students are connecting to rather than the main network, or if the iPads are cellular enabled are they actually connected up to Wifi?

We do have those types of networks, but the students are all on the same wifi here at school. Could using the devices on their home networks cause something like this?

I assume that students/parents can't install their own software on the iPads, but if that's not the case I wonder if some VPN-based blocking software has been installed.

The companion app works just fine no issues.

I guess two other tests you could run are trying to have the affected students access and to see if they have issues accessing either of those two services.

If the network settings of the device can be changed, you might also want to check to see if the DNS servers for the affected iPads are the same as unaffected iPads. Depending on when the error occurs, it might be a DNS issue (but if the school manages them, I expect this would be locked down).