App inventor phone app welcome screen broken

I am a computer science student using app inventor for high school. Over my winter break there seems to have been a UI update that added a 4 panel welcome screen to the App Inventor phone app on IOS. However, this welcome screen doesn't seem to be working. None of the buttons move the screen to the next panel, and I am unable to open the app to the point where I can scan a qr code and sync to my computer. This is troubling as app inventor had worked just fine for the entire first semester. Is there an easy solution to this? Thanks and anything helps.

2 Likes

Hi @Cole_Williams,

Can you let us know which iOS device you're using and the iOS version you are running?

I have a first generation iphone SE and ios 13.6.1

Ok. We will investigate this and see if we can reproduce the issue.

I have also reported this. On my iphone 5se with 14.3 it doesn't work.

Thanks Peter. Do I have a UDID for that device? I may want to send you some debug builds if we can't replicate the issue in the simulator.

Send you a pm.

I've been able to reproduce the issue on our end.

Nice, thanks for the help. Hopefully you'll be able to fix this quickly, but if not, are there any potential workarounds I could use until it is fixed? Like, it is possible to downgrade to the version that worked on my phone before?

Unfortunately there isn't really a way to bypass it at the moment. I have a fix that we are testing internally, and as an additional safeguard it also includes a toggle switch to turn it off in the settings app (it only appears on the first run). If everything checks out we could push out a new version tomorrow.

2 Likes

We've pushed out the welcome screen fix as build 0.9.11 to TestFlight.

Thank you so much, it works perfectly! Now I just have to catch up with the things I got behind on while i couldn't access the app lol.