App Inventor AR Version (Vedlis) Error

Hello Everyone ,,,
I am using Vedils App inventor AR Version , but when i am running to create my apk or generating Qr code through campaign i get this error as the picture below !
how can i solve this problem and fix this error ?

Error Snip :

"build-all-from-zip-async? error: Received exception executing http method POST against URL http://localhost:9990/buildserver/build-all-from-zip-async?gitBuildVersion=none&callback=http%3A%2F%2Flocalhost%3A8888%2Fode2%2Freceivebuild%2F5jtnyi70ty97ucw7l6qll26hw3eat56n5mqhy58yxapltbzjzt292gxdgux60xlh0ei3gqxywm5ub9g9qpaza2z0zvn5jad28u56ibqnvpk7267mb0pmtjytq5mto4y8ffb35unca2p1l2yp0vz4xggn4ssefzlkevh%2Fbuild%2FAndroid: Connection to http://localhost:9990 refused"

thanks in advanced

Hi @Twin_Win,

The Vedils server is run by another university and the project is not affiliated with MIT. It seems like they haven't configured a build server and you may want to reach out to the Vedils team about that.

thank you .. i appreciate your help

Is there any AR/VR extensions are there MIT APP inventor?
I could find the AR components :
with MIT app inventor but I am not able to build the .apk file for my trails to test on Android mobile.
I don't know if it is not released officially or should I ask for permission.

And I went o VEDILS app inventor, where I can try AR and VR trails to show and educate my students,
but I find the same error mentioned above while building the .apk file.

Any help!
Thanks in advance.


You cannot build an apk for your app without without a Vedlis build server. Please contact Vedlis. You are attempting to use a Builder incompatible with App Inventor 2.

Vedliss is not an MIT activity.

There aren't any AR/VR extensions for App Inventor 2 .... see what is available at the list of known extensions at please.

You might try this advice regarding AR/VR with App Inventor

sure, I will try with the extensions you have mentioned and also VR frame work with MITHelper.apk.

Thank you for your quick help.

This server was implemented as a test system as part of an M.Eng. thesis at MIT. It only targeted iOS using Apple's ARKit framework. We are exploring what it might take to bring this functionality to Android, but I can't say any more than that at this time.

Okay , Thank you for your quick response.

How do I get access to use it? I tried and I don't get access