APK installation on mobile

I made a small app using the pedometer. It is working fine during live testing. Once I install it, at the end of the installation process when I should get a message of open / Done, I get a message "App not installed".
This is is the first time I experienced this kinda problem.

One of the possibilities for this message is when the device does not have enough memory for the installation.

Hello Someshvar

Did you change anything between the testing and the building of the APK? Added your own Icon for example?

See my Check List:

Check the version code of your app (it must be > the version code of the previous) and / or uninstall the previous (old) app.

1 Like

Thanks, Anke! I am installing this app for the first time.
I installed MIT Ai2 companion again anyway.

Thanks Anke! U re installed the MIT Companion and it worked.
Thanks again.

I think yes.
I removed some apps and it worked.
Your suggestion really helped me Juan.
Thanks a lot. You saved my lot of time.