Ant devmode in app inventor

Hello everybody,
Hope you all will be fit and fine!
I had recently got to know about ant devmode but after following the guide and when I'm clicking on Dev Mode On I'm getting this error

Help will be appreciated
Thank You

Hi @Horizon ,

Have you ran ant before running the ant devmode because the command ant devmode is for live compilation of GWT code in which our App Inventor's UI is written.

you are going on correct path you just need to drag a Dev Mode On button to bookmark bar. After then go to main page where you are running the App Inventor now click on Dev Mode On link which you bookmarked earlier.


Actually this not an error message it is just saying you that the GWT module is not found on the page where you are.

App Inventor's UI is built with GWT so you need to navigate on that page as I said in my previous post.

1 Like

Thank you @preetvadaliya sir, actually I ran ant noplay not ant maybe due to that it's showing that can't find module, but yes I'll update after trying it

Thank you

Now i have checked the way you told and sir it's working fine

I'm so much thankful to you :blush:

No that does not matter here because when you run ant this will build entire App Inventor system with new companion. but, ant noplay will not build companion, this will only build front-end part.

Yes sir,
I made it work with ant noplay only๐Ÿ˜…
I have got what wrong i was doing, actually I wasn't switching that tab, and when switched the tab and clicked dev mode on it worked

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.