Android 9 - no BLE discovery or permissions requested

Dear All,

I’m trying to replicate an example heart rate monitor example published by Nicholas D’Aquila :

The app builds fine but when it runs there’s no request for BLE permissions and no list to choose a device either.

I’ve double-checked the Service UUID and Characteristic UUID and they are both correct. Also I’ve added the BLE Client and Server components as per suggestion on that webpage so when it runs it would then prompt for the permissions.

All that I get is a black screen.

Is there something else that needs configuring to make BlueTooth work for Android?

Thanks guys,


Almost certainly you have an old BLE extension.
Download a newer version here:
and replace the one you have.
Cheers, Ghica.

I tried swapping in the new BLE library but got some kind of null pointer so decided it’d be best to set up a blank project and build just the bit that connects to BLE and fetches device list & that worked great - thanks so much!! I’d rather do it this way then I’ll learn more.
I’m learning about ANT+ too so if you know of an extension for that it’d help me too.