Android 11 does not work with CloudDB

My mobile was upgraded to Andriod 11, and then no longer worked with CloubDB. It always informed permission Error 908 message, and ask to enable in Setting apps. I located a lot of information, tried "Request All files access" as below:

But, it didn't help, still show me the Error 908 message, and ask to enable in Setting apps. I searched and cannot get a solution. I wonder if any help is available.


Android restricts accessing the file system starting with the SDK30 release... you are only allowed to access the ASD - application specific directory and shared storage, but not any arbitrary directory anymore...

are you publishing your app on Google Play?

  1. if yes, MANAGE_EXTERNAL_STORAGE will not help (except your app is a file manager app or similar), see also 저장소 기기에 있는 모든 파일 관리  |  Android 개발자  |  Android Developers

the app's usage of the permission must fall within permitted uses, and must be directly tied to the core functionality of the app. If your app includes a use case that's similar to the following examples, it's likely to be allowed to request the MANAGE_EXTERNAL_STORAGE permission:

  • File managers
  • Backup and restore apps
  • Anti-virus apps
  • Document management apps
  • On-device file search
  • Disk and file encryption
  • Device-to-device data migration

see also

  1. if no, you have to declare the permission additionally in the manifest of the app...

when exactly does the error occur?
you might want to provide a screenshot of the relevant blocks...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Thanks for quick response.

I am not publishing my app on Google Play, that means MANAGE_EXTERNAL_STORAGE is no use. So, how can I declare the permission additionally in the manifest of the app, do it in aia or apk?

Thanks, JC

Finally, I got it and fixed. More than that we need to change "maxSDKVersion" to 30, as right now it is 29.


wrong... if you do not publish in Google Play, then you can use it

App Inventor targets SDK30, see also the About screen

it looks like you are not using MIT App Inventor... i.e. you are asking in the wrong community...