An internal error has occurred. Report a bug

new app make show error

Click Ok and paste what you see in the new tab opened after that

click ok show this type page
I add only admob component

Looks like you have imported the aia file built with other builder that is not App Inventor. Unfortunately, you can't use that aia file with App Inventor because it doesn't have the "AdMob" component.


Continuing the discussion from An internal error has occurred. Report a bug:

Every time start ai2 error msg or open a project.

After press cancel or esc open project (not the problem) than ok... How can I stop the error msg?

App Inventor does not have an AdMob component. You've likely exported your project from another downstream product. You'll have to first load the project to the other platform, remove any components not in App Inventor, and then re-export your project. The usual rule of thumb is that you can often take an App Inventor project and bring it into a downstream tool, but you can't go the other way because their tools are often strict supersets of App Inventor's functionality.

Export your .aia file and upload it here.

You are posting the error message from another user in another topic?

1 Like

Since your error is the same according to you i merged the topics.

It's not about the aia, every time I open it shows the error.

Ok, so one of my students is having this same message. He has not worked on it outside of class, so the admob thing shouldn't apply here. Can anyone tell me why he is getting the message. This is the screen when ok is clicked after the initial error message

(Canned Reply: ABG- Export & Upload .aia)
Export your .aia file and upload it here.

That will have to happen Monday since I won't see that class again until then.

This issue was reported elsewhere. We have deployed a fix to ai2 to address it a few minutes ago.

I'm getting this issue periodically also. This most recent time was when I tried to copy/paste a control in design mode and now I'm trying to figure out how to restore my app as I can only see the title now in design mode

I deleted the control that I had copy pasted and the other controls came back after I exited the project and came back, so it appears a copy/paste of a control causes some sort of corruption that can be fixed by removing that control