An internal error has occured

Hello to everyone. I would be grateful if someone could help. I 've been building an app lately and had no isuues so far (although I know the code hasn't been perfect, the app was working) . But I created one more screen and now when I'm trying to build the app I get this error : "An internal error has occured. Report a bug" The details of the bug are these:

Technical Data to be Submitted:

notes = Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0
foundIn = nb190b
faultData = Error parsing JSON: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
projectId = 6188326055706624

The weird thing is that I'm testing the app in the companion and it seems to be working ok. But when I'm trying to build I get this error.

From the details above does anyone have a clue of what could be wrong? Thank you!


It seems there could be a problem with the buildserver. I contacted the developers so please be patient.

Working here, was able to compile om main ai2 server. 17:36 GMT

Didnt work for me a couple of minutes ago with the same error message. Will test again later.

Still the same error 19:05 CET.

1 Like

I'm looking into it... we are running on AWS buildservers at the moment.


Same problem with build apk and aab.
notes = Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
foundIn = nb190b
faultData = Error parsing JSON: SyntaxError: Unexpected token 'B', "Build serv"... is not valid JSON
projectId = 4869193597321216

1 Like

Thanks for the immediate reply.... at least I know it's not something in my code.... I guess we have to wait and be patient

Still compiling OK here (UK) 18:20 GMT

Same error (Spain) 19:38

Is the error transient, or is it consistent. If you try multiple times does it sometimes work?

It is consistent. Just tried 4 times and every time the same error message.

In the case of simple applications it is possible to generate the .apk but in applications with multimedia files the error is consistent and cannot be generated.

Can you send me the .aia file?

Send you a pm.

You are right. Just tested it with a small project.

OK, try it now. Evan reminded me that we had this issue on the MIT based buildservers. The fix just didn't get put on the AWS buildserver set. I just updated them.

The problem only affected large projects!

P.S. We're running on the AWS buildservers, just to make sure they work. This coming Saturday, our building on the MIT campus will be powered down, so we will be running buildservers out of AWS. The same thing is supposed to happen on the following Saturday as well.

I could watch them today (thus being in a position to fix things), but on Saturday I won't be able to keep a close eye (at least not until the afternoon), so I needed to know that we won't have problems on Saturday!

P.P.S. This server is in AWS always, so won't be impacted by the power shutdown on Saturday. BUT it may not be able to send e-mail. The e-mail server is on campus, and in theory is on backup power, so should stay up. But who knows...

Moving an e-mail server is a non-trivial exercise, because you cannot run them in most cloud systems, and your sending reputation is tied to your IP address, which is in turn tied to the physical network, which is in the building on campus!