aiStarter Python error Emulator does not run

I searched the forum and found another user with the same error in 2021, but no answer as to how to fix it. Here is the issue:

After installing the emulator, it wouldn't run. So I ran Terminal, found the app folder, then found aiStarter. I ran, from Terminal, ./aiStarter, and this is what it told me:

MacBook-Pro:commands-for-Appinventor tomdowad$ ./aiStarter
[621] Error loading Python lib '/var/folders/mx/27frfycj64538crxj2h3lvj40000gn/T/_MEIp7VIii/.Python': dlopen: dlopen(/var/folders/mx/27frfycj64538crxj2h3lvj40000gn/T/_MEIp7VIii/.Python, 10): Symbol not found: _getentropy
Referenced from: /var/folders/mx/27frfycj64538crxj2h3lvj40000gn/T/_MEIp7VIii/.Python (which was built for Mac OS X 10.12)
Expected in: /usr/lib/libSystem.B.dylib
in /var/folders/mx/27frfycj64538crxj2h3lvj40000gn/T/_MEIp7VIii/.Python

Hello Tammy, welcome to the forum

Can you screen capture the error and upload it here please. A lot has changed since 2021.

Yes. It appears to be the same error as the old post I found.

I have assigned your Topic to Susan Lane, she is the Emulator Guru :grin:

Please let us know the exact version of your computer's OS.

What version of macOS are you running?

OS X - El Capitan

I am running OS X - El Capitan

There should be some version numbers too - the latest version of El Capitan is 10.11.6. It's old, 2015, and Apple no longer support it (same as Microsoft no longer supporting my Windows 7, but App Inventor does).

I think it may still possible to upgrade your OS, should that be necessary, let's see what Evan or Susan think.

There is a build of the emulator package floating around that is built for 10.10 and later. I'm not sure whether that is the version I have currently installed but I will see if I can locate the installer.

Here's the latest version I have of the 3.0 series of builds for macOS: Dropbox - MIT_App_Inventor_Setup_3.0.1rc1.dmg - Simplify your life

Thank you, everyone! The parent who sent me the error messages and images, etc, seems to have it running now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.