aiStarter For Emulator

How do we square this triangle:

Did you re-install aiStarter and tools?

Which version you are using? The BETA emulator or the very old one (2.3.0) ?

What OS are you using? I suspect it's Vista.

Hi AyProductions

I started the topic simply because we have a few holes in how necessary information is delivered to new Users (Devils Advocate). For example, clicking the link '/need Help?' does not take you to Emulator or aiStarter Help. If you find the help yourself, you will also find that the download is insecure and your Browser expresses extreme concern for your well being :grimacing:

You have asked some good questions but if you are going to help someone with this then you should have explained how to find out what version is being used. Note, aiStarter.exe does not state it's version in Properties, but the version is part of the name of the Tools installer. Also note that you cannot identify the Emulator version if it does not run. It is good to verify the User's OS. In my case, It's not Vista, but it is an older version Windows - Win7 64bit, so good guess!

Edit: The latest aiStarter for Windows appears to match the OS bits (so 64bit on my PC). Takes a while to install (it's big) and also installs an Intel hardware accelerator. When running, it gives it's precise version, 30.265.0, which is a nice touch. It's not working for me though.

1 Like

Weird, It worked for me on my Win7 laptop and Vista PC (2.3.0, 30.265.0 it didn't run on Vista, but in Win7 the graphics were slower than Win10. I do have a Win11 laptop, except I can't test on it)

I thought it was vista since aero couldn't run on most PCs, well I hate to say it, but I got it working.

You are using Google Chrome 106 right? or Brave? In Brave, disabling Brave Shields for will work, at least that is what was pointed out by @ABG.

Does it still show the same error?

Pro Tip: Download claiming to be insecure? Right-click on the download link and paste it on a new tab, since right-clicking and opening it in a new tab won't work.

... I'm actually using FireFox. It very nearly worked, first attempt displayed a Google Pixel 4 emulator, second attempt displayed the 5554 emulator, both decided they couldn't be bothered to load the project. I never use the Emulator, the Companion on a selection of Smartphones is much more useful, but if we provide an Emulator, it should work.

Downloading via Chrome, you can elect to ignore the warnings (currently).

No no, because this time the aiStarter matches the Emulator and App Inventor. It just gives a pretty generic "not responding" error.

I had a rough install over the old emulator.

There needed to be a good cleanout of the old version, from its old directory.

Use Windows Task Manager to get a handle on how many instances of adb.exe are running. That can confuse aistarter.exe at startup time.

Check the emulator settings for its adb.exe connections.

If HAXM gives you trouble installing, check your UEFI Boot VM support options, of which there are several.

Assign this thread to @Susan_Lane

I thought the Emulator had been sorted, Win7 is old but it's still popular. I have put more detail in the Power User Group - I don't think it should be so difficult for new Users to find the documentation and the download.

It works fine for me on my Win7 desktop now.
My Win11 Home Acer laptop still resists the HAXM install.
Sooner or later the Microsoft VM option will arrive on my Windows Update stream, and I'll try that.

Did you install it from the installer or are you running it as part of a zip? If zipped, unless you relocate the files to C:\Program Files (x86)\aiStarter it can't launch the emulator. I may be wrong, but I did that before and got the exact same thing as you.

1 Like

A proper install - and it installs nicely @ 64bit OS and also uninstalls nicely (3 registry entries left behind but all the files in Program Files are all deleted).

I did not uninstall the previous 32bit (x86) version as when we where testing early version 64bit that was deemed unnecessary - but I'm uninstalling both right now and then re-installing the new 64bit version just in case.

1 Like

Are there any browser extensions intercepting with App Inventor?

Nope - it's good to watch out for Anti-virus interceptions though, they will cause havoc.

1 Like

Yes. This reminds me of those hectic times of Antivirus blocking programs, and not letting me test my programs. Anyways, for the HAXM, I think you need to install the graphics driver at least, or is it because you are using an AMD processor?

What about trying ?

Already there for other much more intensive graphics programs.

I'm using an Intel i5

I think you are very lucky.

But did you install C++ redistributable?

and Did you also install Python 3.7 or 3.9?

Installed the C++ redistributable - python not required?

Yes! It is required.

It is not mentioned during the install nor was it during the testing way-back-when and there is no error error message related to python when running the Emulator. Are you sure it's not required for Linux OS rather than Windows? The installer is 1.5GB already.

Also, did you update Windows 7 with service packs?

That's an old post by Evan, not sure it applies at all since the new version is 30.265.0, the first 64bit - I mean, it installs everything that is needed, so if Python is needed, that should be installed too.

I have to break from this Topic now and update the one in the Power Users Group before leaving my PC until tonight, but if you have more ideas, keep them coming!

1 Like