AI2 project is not getting saved

I am creating an app that has 10 screens. One night I saved the project and it showed the confirmation message. The next day I found that the changes that I made last night weren't saved. I have started to encounter the problem once the blocks on the screen were more than 1000. In all the project has approximately 2500 blocks and I will have to add another 2000 blocks to complete the project. Is the problem related to my system hardware or is it a MIT server issue?
Any suggestions on how to fix it?

hi @Alaqmar_Bohori
that might be due to network problem
It shows that your project is saved but it really isn't (according to me)

My internet is working as I can see the changes on my companion.
The only hindrance is that whenever I close the tab or if the session reloads, the changes aren't saved.
I am working on my project right now and I was able to see the "Saved Project" message but suddenly i got a message asking to reload and the changes which I made today weren't saved. (I was able to see the current changes on the companion just a few minutes ago).

I don't know about this but i am pretty sure that it's due to network problem . Network problem doesn't occur daily. right?
Well, i said you this as i have faced this many times
& concerning about the reload message - it comes when app inventor has been opened on your desktop since a very long time & you haven't made any changes yet

Were you getting a message like "Loading" when you saved the project?
That is in itself a big sign of network problem

Yes, I get such a message. I am connected to my broadband and everything works fine. Could you let me know if there is a specific setting which I have to change.

Safest method is to export your project to an aia file on your computer

1 Like

Not really because there is no such setting

i am too
but that really doesn't mean that it is always going to work great
at times there is net problem
Edit: My network too worked great but i think that it was MIT app inventor unable to detect it

Hi @Alaqmar_Bohori
I don't know what exactly is the issue if it's not Network issue
But maybe you can try instead of saving the project use the "save as option" and see if it works
and if it does then continue working in that saved copy of your project
(I usually prefer such odd solutions to my issues when I can't really seem to get any help)

@Alaqmar_Bohori, you should do the same suggested by @TIMAI2

1 Like

Have you ever tried save as @Shruti ?

@TIMAI2, I made a few changes and downloaded .aia file of my project. It did save some of the changes but not all; it was inconsistent in storing all the code and designer changes. :worried:

@Shruti I have already tried this option but it didn't work.

So you are still facing this problem ?
Even now when you change your code it isn't saved?
or it was jut at that time when you reported this problem?

No it is still happening :frowning_face:

So there might be another problem

NEVER....seen that before!

My guess (without seeing your aia project) is that you have issues within you blocks / design that are causing problems, or that your project has become corrupted.

I wouldn't have said If I didn't knew ....... :koala: :panda_face:

  • Have you been using the checkpoint save system of AI2?
  • Has this project been imported from another AI2 spinoff?
  • Does this project have unexplained content in its Media folder?

Instead of the checkpoint, I use save as.

No, it's an original project.

No, I have only 2 pictures(png) in the media!


I get this message quite often!