AI2 Companion screen white

When one of my students tries to test her app on her tablet, the MIT AI2 Companion app on the tablet only shows a white screen. We have logged her in to different computers and used multiple tablets with the same result. She even tried to use her sister's tablet but had the same result. When her sister uses that same tablet to connect to her own MIT App Inventor account to test her apps, it works fine. It seems like there is an issue with this particular student's account that is causing the problem, not the computer or tablet. Any suggestions? I would like her to continue to be able to use her school gmail account to log in so don't really want to have her use a different email.

Welcome Judy.

Is her Google account for a person under age 13? That could be the issue.
If this is the case, she can log into MIT App Inventor server. It can be used by developers without an eMail account. She creates a Revisit code account.

Click on Enter with Revisit Code and a Revisit code will be provided in the empty spaces. Keep the code you receive in a safe place. She cannot return to her Projects without having the code.


If no one else has a solution; you might try that for your student.


It may also be an issue with the particular project. You may want to have your student try one of the sample projects to see if it loads. For example, she can load the HelloPurr app by going to Projects > Import project from a repository and then select HelloPurr from the list that appears.


This project should work on all versions of Android and iOS. If it does, you may want to have the student share the project here (or you can send an MIT member a private message with account details and we can look up the project in the student's account). If it doesn't, we will need some more information about the student's setup, such as which browser they are using (Chrome, Firefox, etc.) and version numbers.

Thank you for your help! She is over 13 and, while she doesn't remember exactly, she thinks she did get the age question and answered that she was over 13. I shared your response with her so she has a way to check her apps for now until we, hopefully, can fix her account. Thanks again!

Thanks for your feedback! She has tried several different apps. The first was the App Inventor Template Welcome App in lesson 1.4. It opened on the MIT AI2 Companion on the tablet but as soon as she started editing the app as directed (changing the background color, etc...) it stopped working.

I am attaching some screenshots of what my student sees. The first is as she enters the code on the tablet. The second is the blank white screen she sees. The third is the error message she gets when she tries to use the Refresh Companion Screen under Connect in MIT App Inventor on her Chromebook.

There are several coding issues Judy.

  • Your student is using a very old version of Companion. She should have 2.60 uploaded on her tablet. She can download the latest version from the Play Store.
  • the runtime error is possibly due to her manipulating the Screen1 Theme Property. Possibly she selected Dark? Change it back to Classic as a test and see if she sees something other than a white screen.
  • the white screen possibly is an issue with how she set some color settings. Without seeing her aia, I can not tell exactly what the issue might be.

She can test by making a new Project. Simple, just place a Button on the Designer then use the Companion to run the app. Does she see a Button?

  • the problem might actually not be related to her log in based on your description; it might have to do with the Project she has loaded. Load a different Project as a test. What happens... maybe that will fix the issue?

I concur that the primary reason is the out of date companion. I think 2.44 is at least 2 years old. You will want to update to the latest version and any errors about missing properties should go away. These errors will prevent other things from working correctly and once resolved should fix most if not all of the remaining issues.

Thank you! Updating the app did the trick. But, here is a slight twist. Two sisters are in the class together. Both use school provided Chromebooks and tablets and are on the same networks at home and at school.

The one sister was having the issues I explained -- screen on tablet was white. Her sister had no issues -- hers worked fine. Both had the old verions of Companion (2.44).

The one sister with issues tried using her sister's tablet -- screen was white. She tried running a different project, including one of the sample projects provided by MIT -- screen was white.

Updating to version 2.6 fixed the problem so we are good to go. But, not sure why it worked for one sister but not the other. Weird(-:

Anyway, updating app was the answer to get her going. THANK YOU FOR YOUR HELP!!!

Updating the app fixed the problem. Thank you for all your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.