AI Companion fails at 20% loading

When I connect an Android phone to test, It never loads past 20%. This is now happening on multiple apps, two different computers and two different phones.

I have tried clicking the "Use Legacy connection" box. No help. Tried different browsers too.

1 Like

@Greg_Doud This should work

Steps that might help
  1. Reload
  2. Log out and Log in from MIT App Inventor
  3. Restart your laptop
  4. Clear Cache
  5. Close much internet consuming tabs
  6. Delete unwanted files
  7. Try to clear RAM

This might help you

  1. Create a dummy project
  2. try this project to connect with companion then go to the project problem solved

this occurs because high asset or many extensions

MIT's AI2 servers are overloaded due to hardware failures, and their configurations try to share the overload. Unfortunately, that spreads the problem to build servers and Companion connection servers equally. This won't be resolved until new hardware arrives, or funds for paid Cloud servers arrive.

1 Like

Can someone please :pray: explain to me → what the problem is using one of these two options → until this issue is resolved?

Both work fine. There is no need at all to build APKs for testing!


Thank you for your reply. I have tried these steps to no avail.

I did try to open the companion with another recent project that was very simple. I encountered the same problem.

I'm not sure what you mean by "high asset" Does this mean lots of code blocks?

Thanks for taking the time to help!

How did you try Greg?

On your PC, click Connect> Companion This will elicit a QR code on your PC screen.
On your Android, click your Android MIT AI2 Companion icon.
When Companion appears STOP a second and tick the Use Legacy Connection check box; and only then use the blue scan QR code button and scan the QR code.

MIT is having sever server issues and is acquiring new server hardware. This work around avoids the 20% issue it appears for all but you. You say it does not work for you.

Same problem. Legacy unchecked, it hangs at 20 percent. Indefinitely, it appears. Legacy checked--I get some connection error message. Fairly quickly.

Time to go to lunch.

Hi, I am having the same problem as Greg and Richard. I have tried a few methods with the following outcome.

Stuck at 20%:

  1. Chrome + MIT Companion
  2. Chorme + Bluestack using MIT Companion
  3. Firefox + MIT Companion
  4. Using another windows Laptop, Chrome + MIT Companion
  5. Tried scanning with another phone, Chrome + MIT Companion

Loading bar will load until around 80+% or 90+%, and get stuck at the last download png or wav file. However, for games without any download required, the loading bar will not even appear at all while the MIT Companion will be stuck at the enter code page forever:

  1. Chrome + Legacy MIT Companion
  2. Chorme + Bluestack using Legacy MIT Companion
  3. Firefox + Legacy MIT Companion

Hi SteveJG,

I have done as you described. Still same problem.

Thanks for taking the time,


Just for reference, I too have the 20% problem. Tried using Chromebook + Companion app. Also android tablet. Also legacy. No luck. I gotta believe the hardware server story is the correct one.

Sorry work arounds are not working for some of you. Work arounds do work for evidently some and myself (in Texas) See Unable to Connect to Companion with AI Companion

The following ameliorate the MIT server issue (for some)

  • check Use Legacy Connection on Companion before scanning the QR code
  • using the emulator. Yes it works.
  • using the USB connection option
  • using the MIT code.appinventor alternative server also is affected.
  • compiling your app and testing. Tedious but several users say it works. :frowning:

MIT is trying to fix the issue going so far as to replace existing server hardware. This may take some time. Please be patient; eventually the server will be back to normal.

The issue for some of you may be your existing Project having issues. You can test this by creating a simple Project (place a Button on a form) and using Companion with Legacy checked.

Seems to be a bit on and off, one minute it won't connect (legacy ticked) then next minute (or a few minutes later) connects just fine.

1 Like

I have no problems with USB connection at all (Firefox / Chrome).

1 Like

When I scan the QR code it says "20 Establishing secure connection". But then it stops there and doesn't proceed. Please fix this problem

Have you tried above solutions ?

Hey Gerg did your issue got fix?I am also facing the same issue and my student as well.i used to take classes for MIT and its going tough for me to explain the concepts with out showing the output please help me if it resolved.

The MIT server is still having technical issues. We do not know how long this will take to fix however there are several relatively easy ways to continue developing despite the MIT server issues.

  • check Use Legacy Connection on Companion before scanning the QR code. Checking works for most developers and will get you past the 20% loading issue.
  • use the emulator. Yes the emulator works.
  • use the USB connection option
  • compile your app and test. Tedious but several users say it works. :frowning: If you are not an advanced user, I do not recommend this.

Try these options and tell us which work.

MIT is trying to fix the server issue, MIT is replacing existing server hardware. This work may take some time. This might not be fixed for several days. Please be patient; eventually the server will be back to normal. However most developers can continue to use App Inventor using Companion with Legacy checked or one of these other options until full service is restored.

Hi Zeba,

I saw SteveJG replied already. I have not gotten it to work, and I too am stuck with my students who cannot test their final projects as they code. Sounds like we wait. I have had a little bit of intermittant success by checking the "use legacy connection" box, but not much.