Afterpicking with listview doesn't wait anymore for choice

When I call for listview the steps are taken already with the first choice of listview. It doesn't wait. I can't find the problem. First It worked fine.

Please show your relevant blocks

These are relevant blocks. I've generalised a input listview. After that a choice had to be made from witch blockit comes to proces the choice.

Here it starts

You appear to be using a dialog extension ? (DialvnHlp. Show/Dismiss) ?

Exactly. I've got the tip from you and I am realy glad with it

Could this be the cause that trips the listview selection?

In this dialog there is a generic listview

I don't know but maybe it can....

What do you mean bij "trips"

Makes the selection happen

Oke, yes it does. Would you like to see this screen?


But it should wait here doesn't it?

Try taking the listview out of the dialog, and just have the listview viewable in your app (do not call the dialog). Does it still auto select ?

Oke I'll try this

Your right. Now it works fine. Thats a pitty. I loved this dialog box..

I suggest you make a simple example with the dialog and a listview, to see if this behaviour is repeatable (which you could share here), or if there is something else in your blocks that is causing the problem?

I am going to that. Thank you for your advice. You'll be hearing from me.