WebViewer dont show videos (it just show a blank space)

I am creating a page to log into the TPlink cloud camera where we can view the live footage from it's website.

I've loaded the link of the website into MIT Webviewer and realize the video is not showing like it suppose to.

this is what happened in the WebViewer.

I've thought phone cant support the type of video and so I tried open the link with Chrome. it works there.

how do I make the Webviewer to show the video like it shows in Chrome?

And the link? What does that look like?


it is just the link where the camera keep the video

What url or an example of a url are you using to show the webcam in the native browser?

Is this the url you are looking for? (https://www.tplinkcloud.com/)
I use this url with WebViewer and log into my account from there to see the webcams video.

it is suppose to be cloudbase webcam where I can see the video anywhere.

  1. Looks like you can find the IP address for your camera on your local network

  2. It appears a web browser plug in is required ?
    This may mean it will only work with the native browser, in that the App Inventor webviewer cannot load such a plugin. I don't know...

  3. They appear to offer an android app already ?

Yes they do offer an android app for it.
my project required me to run it in the App Inventor.

if the plugin cant be run in the App inventor. I guess I have to use another ways to show it in the App inventor then.
thank you so much. :pleading_face: :clap: :clap:

It may be worth trying:

1 Like

I solved my problems by referring to this

by using it, i manage to call chrome applications and link to the url.
when I click onto back button, it went back to the application.
it works so well you even feel like the chrome application is part of your applications.

thank you! @TIMAI2 for your helps and suggestions! i really appreciated your help! :smile: :smile: