Webviewer and Form

I am tryng to add a link in my app via webviewer but the final page of the form fails!

here it’s my aia file!

Why fails only that page?

beauty.aia (14.4 KB)

this is the form i add

is it an issue of the webviewer?

What does that mean? What is the final page of the form?
Explain it in more detail, screenshots etc ...

the form has 5 pages! the last one send data to a spreadsheet of google drive…

in normal browser works… in webviewer NO!

If you are asking for help, I recommend you to make it as easy for others to be able to help you …
You probably will get more feedback then…

which means in your case post a screenshot of your relevant blocks…

To download the aia file, upload it to App Inventor, open it, do some bug hunting for you, etc… this takes time, and most people will not do that…
Thank you.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

i only added the url of a “google form” in webviewer that is connected to a spreadsheet !

This form is of 5 pages the first 4 pages are ok while the last one

works on browser (chrome and browser of smartphone ) while in webviewer i cannot vlivk on INVIA!

Your shortened url does not work.

link is here and in aia file

The WebViewer is not a full browser.

Jotform web pages are built up from Javascript frameworks with a pinch of html.

Use your Chrome developer tools to look.

I was able to extract a URL from them:


I have no idea what will happen if you try to go to that URL.

Try this new extension:

1 Like

do i have to add also normal viewer? seems that is not present the custom webviewer

use the CreateWebView method together with an arrangement of your choice, see also the documentation




thanks! works fine…

1 Like

sounds good :heart_eyes:
If your problem has been solved then let others know by marking appropriate post as solution :slightly_smiling_face:

Sure it’s a promising project and solves a lot of problem of normal webviewer

1 Like

(added to FAQ)

Thank you Sir :heart_eyes:
But you have written Sonny instead of Sunny :sweat_smile:

1 Like

I fixed it.
Maybe at my age any one under age 65 is “sonny”.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.