Video player error:undefined

Sir i tried to upload this file in the assets but i got a error message that the file is too big then i tried another file (this one)
this is also not uploading on the assets can you help me

Use cloudinary, I personally suggest it



see my new code

cloudinary url

still not working

error message

if you want i can share the aia on pm

You want to use this video as the background if yes can I give you a suggestion...

Start the video when button click

1 Like

yes i want to do that only

i dont want to do that

Once try this

1 Like

First, think about what player you want to use. You create a topic with a built-in player and in the meantime you switch to the extension.

I'm facing the same issue. I'm trying to embed this video:

The video is 849 Mb. You cannot add it to your Project. Have you tried linking to the url (setting the VideoPlayer.Source to the url of the video?

1 Like

Yep that's exactly what I've done. I also tried adding a 'PRESS TO START' button but it shows the same error.

Perhaps because

Documentation for the VideoPlayer indicates you can also set the media source to a URL that points to a streaming video, but the URL must point to the video file itself, not to a program that plays the video.

The link points to a program that plays the video. :cry:

1 Like

I don't think so for in this case, the video player is this and the corresponding video file is this: Now this has to be a video file since it ends in .mp4.

Nevertheless, could you give me a link to a video file that plays perfectly in the VideoPlayer without the error popping up?

It appears from the conversation in the community the VideoPlayer has issues playing mp4 files directly from a url. The apparent work around is to download the video and play from a non asset directory.

1 Like

I am currently using the WebViewer and using the Call WebViewer1.GoToURL to play the video by pasting the video URL in this block. It kinda works but does not give the flexibility and fluidity of the Video Player, which in turn fails to provide the best user experience. I hope the @MIT AppInventor team fixes this issue soon. Thanks for your inputs though (:

Use this extension


It does not seem to work in MIT AppInventor.


Your Blocks?