Using serial with FTDI

Updated SerialOTG with PID/VID 0x1A86, 0x7522 LD-C100 USB TO CT-62 For Yaesu, driver CH34x in my github debug directory. Please test it and report.

Thanks Rolf @rkl099 rkl099 !
Works just great

hi! I saw your app, it works well with Arduino, can I use the same to access the UART of Raspberry pi4?

Yes, but you need an USB-serial adapter with ttl output/input (0-3.3V).
USB-serial with Rs232 out/in will probably destroy the serial in/out on the Pi4.

The simplest logic level converter is enough

Greetings. I'm testing my Chinese NANO V3 with version 1.5 and test apk from archive.
It works great in conjunction. There is no disconnect. But it's worth pulling out and re-inserting the usb connector and I can't get back the connection with the Arduino in any way.
It only helps to exit and close the application. After restarting the application, the connection appears, but until the USB is disconnected.
Question: "Is this normal?, or is there a workaround?"

Try to close the connection, before you disconnect the USB.

Thank you very much. I achieved stable operation using the "Close" method and the "USB Detector" extension. Now for me USB works stably when connected or disconnected and automatically restores the connection. Thank you.

Maybe a good idea would be to add the USB detect method to the extension and disconnect it automatically after removing the USB plug?

Dear Rolf @rkl099,

Have you finalized version where one can add VID/PID at will ?

I run into 2 serial2usb that my app with your OTGserial does not recognise:

  1. dongle for Yaesu: FTDIBUS\VID_0403+PID_6001+AQ02YL6XA\0000 (FTDI)
  2. Icom IC705 itself: VID 10C4 , PID EA60 (Silicon Labs)

I'd appreciate much your help once again. I it is not possible/You don't have time or abandoned it - it is perfectly fine.
Best regards,

Try using the function to force the driver: USBdriver(int). Look in the documentation for SerialOTG 1.5 to se available drivers. Note: The library can only handle one USB-serial device.

Thanks a lot for yr support and great version 1.5 (with docs and samples).
I still need to understand how to reset (both sides?) so that after wrong guess I can make device respond.
All the best and thanks again

I use Linux and command dmesg in a terminal window to see what device is detected. You can also do this in windows to see the hw devices connected.

Hi all,
I'm using SerialOTG V1.5 to send a reasonably large file and noticed very slow transmission, just wondering if anyone also notice the same issue? I've created a new issue on GitHub with details of my setup.

I've tried both the Write() and WriteByte() methods, same result for both.

Note that in the above blocks, I'm sending a constant string for consistency during testing.

Test WriteBytes() using a list of bytes as data. I think WriteByte() writes a single byte to USB for each call. Please return with result.

@rkl099 Thank you for getting back!
I tried your suggestion and the result is the same, here is my new block using WriteBytes(),

@rkl099 thank you for the extension! Is it possible to specify PID/VID of the device I want the extension to look for and connect to? It appears that it's trying to connect to the first USB device that comes across its way, but it's usually not my serial device that I would like it to connect to. Any pointers?

edit: more about my setup: I have a USB hub attached to my Android device, and the app is attempting to connect to the Ethernet adapter on the hub instead of my serial device (Adafruit QT Py M0). If I disconnect the hub, and plug the microcontroller directly into the phone, my application is able to communicate with the microcontroller correctly.

Your observation is correct. It's a limitation in the original library. Some parts must be rewritten to handle a specified VID PID and multiple USB devices. Maybe in the future.

Excellent work! :blush:
I wish I could read a parallel port via OTG. Do you think it's possible with your extension?

Sans titre