The simplest AI2 compiled app "keeps stopping" on my phone

The only thing I can see that is a bit strange is the . at the beginning of your API key (Firebase token). Not seen that before?

Interesting use of tags without any Project Bucket.

TIMAI2 thanks for the quick response.
I am very new to AI2 and am not sure yet how Project Bucket work so I will go and learn how to make use of it...
Not sure how this . has appeared? mayve a cut&paste error...
I have tried to remove it but it does not make a difference to the app crashing.

You do not need to state a Project Bucket in your designer settings if you do not want to. Your tags will be set under the main node, e.g.

--myTag: "\"123\""

You also do not need the / at the beginning of your tags, so myTag works the same as /myTag

Just looked at your project again

Firebase token should be:


Firebase url should be:

Setting these makes your app run for me in companion app

The firebase url does not appear to be listed in the firebase config data any more ?
Look in the realtime database console, the url should be at the top above your data

Thank you TIMAI2 for the useful advice.
I have tried the following:
I have created a simpler app like so: IoT_Firebase.aia (2.9 KB) making sure I specify a project bucket this time and fixing the Firebase credentials and db address.
Again all works fine in the Companion app but crashes when I create an .apk on the phone.
However if I remove the Firebase component (and corresponding blocks) the app runs fine on the phone.
I don't really now what to do next...

OK, you are getting an error i have seen before which is related to using the EU firebase server.

Suggest you setup a new firebase project which uses the US firebase server and try again


Yeaaahhhh Success !
TIMAI2 I did what you suggested (US db instead of Belgium one) and it all started working!
Many thanks for the quick responses TIMAI2.
Do we know what the issue is with the European Firebase server in Belgium?
Do you know if there is a way to be informed of fixes/updates? It would be more logical as I am based in the UK.

In any case a ton of thanks for your help!

Not sure why, it worked ok a couple of years ago, and is still working for the project I set up then,but not now for a new project.

2 posts were split to a new topic: App keeps closing