SSL connection error when connecting to a Redis CloudDB

Hello, I have created a free account at (30 MB, 30 connections) in order to learn how to use the CloudDB block in AI2.

I have created a very simple project which stores a value in the DB, then retrieves it and shows it on screen.

When I disable the “UseSSL” option, everything works fine. However, when I enable this option, I get a connection error. Please see the screenshots.

I am running the AI Companion in a smartphone with Android 8. I do not think that my mobile is that old so that it does not trust the Redis SSL certificate. Has someone experienced the same issue?

Thank you.

Yes, I found this when setting up redis labs.

It is currently a workaround, not a solution, but that is all we have… @jis

According to, the free tier (Cloud Essentials) does not come with SSL support.

1 Like

Thank you ewpatton, I had not realised it. Then it was only a decision they made to not support SSL in the free plan… makes sense.

After some investigation, I noticed that all the big cloud providers are offering a Redis service:

  • Google (this one does not support persistence)
  • Amazon
  • Azure

Now the question: has someone tried to access any of this services with AI2’s CloubDB, through a secure SSL connection?


Because they are all payable services (yes, some have a trial) most hobbyists here will not have tried these.

did you just input the server port and security code in your clouddb app in mit??

As previously advised elsewhere, the online providers for redis servers will not work with SSL on App Inventor due to the different method they use to handle SSL