Reload old project


Years ago I created 2 projects on App Inventor, I guess it was still AI1.
I would like to do some changes on the Apps but there are not on my account anymore
I have a local backup but there is no AIA file, just the files here below

Any idea how I can load these projects on AI2?

pack this with winzip to a zip file, change the extension to aia. then import the aia file.

That worked to import the project but unfortunately it's incomplete
Here is the AIA file. As you can see in the BLK there should be some calculation called by the CalculCmd button but there is nothing imported in AI.
Any idea?
Thank you for you help
ARMode.aia (32.9 KB)

Sorry I am not familiar with the structure of the bky file.
Maybe other PU can help.

.blk was the AI1 blocks format whereas .bky is the AI2 blocks format, and old AI1 projects used the .zip extension rather than .aia. The two formats are not directly compatible, but there is a converter tool that should be able to update the project to the newer blocks format.


Thank you for your answer
The link to the converter tool doesn't work. Maybe not available anymore?

Last time Sep 2021:

convert your AI1 blocks to Ai2 equivalent blocks manually:

Here are some resources to help you learn to use the AI2 tools. A very good way to learn App Inventor is to read the free Inventor's Manual here in the AI2 free online eBook App Inventor 2 Book: Create Your Own Android Apps ... the links are at the bottom of the Web page. The book 'teaches' users how to program with AI2 blocks.

There is a free programming course here Course In A Box and the aia files for the projects in the book are here: App Inventor 2 Book: Create Your Own Android Apps

How to do a lot of basic things with App Inventor are described here: How do you...? .

Also look here App inventor español. Offline. Tutorial. Ejemplos. Instalación. Códigos. Juegos. Curso gratis de App inventor. and here Tutorial Index | Imagnity for more tutorials

Learn about components Component Reference
and visit the Library The MIT App Inventor Library: Documentation & Support Help>Library on the MENU


The server has been shelved for some time since it wasn't seeing any use. We will need to upgrade it before we can bring it back online.

I'll try to recreate the part that is not loaded from the old project.
Let me know if you intend to put the converter back online
Thanks all for your help.

I have revived the server. You can now go to (it will also work over https after a few hours).

That worked perfectly
Thanks you so much for your very quick reactivity

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.